[POJ2386][OpenJudge] 2.5基本算法之搜索 Lake Counting

10 篇文章 0 订阅
8 篇文章 1 订阅

一、原题

描述

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

输入

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

输出

* Line 1: The number of ponds in Farmer John's field.

样例输入

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出

3
题目大意

二、分析

这道题可以用宽搜,也可以用深搜,至于不知道这两种搜索方法的同学可以去“ 百度 ”或“ 谷歌 ”一下。我用的是深搜的方法,每找到一个水洼"W",可以用"."填坑,然后每搜索到一个连续的水洼,答案+1,然后把水洼填掉,来计算水洼的数量,从而不重复计算。

思路

三、源代码

#include<cstdio>
#include<iostream>
using namespace std;
char a[105][105];
int ans,lr[9]={0,0,1,1,1,0,-1,-1,-1},ud[9]={0,1,1,0,-1,-1,-1,0,1};
int n,m;
void dfs(int i,int j){
	if(i<1||j<1||i>n||j>m)        //越界返回
		return;
	a[i][j]='.';                  //填坑
	for(int g=1;g<=8;g++)         //把周围的坑都填上,而且重复搜索
		if(a[i+lr[g]][j+ud[g]]=='W')
			dfs(i+lr[g],j+ud[g]);
	return;
}
int main()
{
	cin>>n>>m;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
			cin>>a[i][j];
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
			if(a[i][j]=='W'){dfs(i,j);ans++;}
	cout<<ans;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值