【树状数组】Stars

                                        C - Stars

 
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

#----------------------------------------------------------------------------------------------#
题目大意:按y的升序(y相同则按x升序)给出n(1<=n<=15000)个星星的坐标(0<=x,y<=32000),每个星星左下方(包括同一行或同一列)的星星个数为它的“等级”,依次输出等级为1,2,3,...,n-1的星星的个数。

最后提示用scanf,最好不用cin

#----------------------------------------------------------------------------------------------#

思路很容易:树状数组求x的“顺序对”,因为y已经按升序(即从低到高)排好序,所以只需要知道有多少个星星的x坐标小于当前星星的x坐标就可以了。

怎么用树状数组求x的“顺序对”呢,先解释下顺序对就是它之前的数当中比它小的数的个数。

然后,就容易了:将星星的x坐标的位置+1,当然是树状数组的+1,然后,x的getsum就是它的等级了。


why?


因为:x坐标+1,就表示了x那一排多了1个,而y坐标是递增的,每个点只有一个星星,所以当前x的getsum就代表了当前x坐标比它小的星星数量。

原谅我只能这样描述……自己体会吧。


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lowbit(x) x&-x
int n;
int tr[32005];//树状数组
int ans[15005];//存每个等级星星数
void update(int q,int x)
{
	for(int i=q;i<=32001;i+=lowbit(i))//注意i<=32001,这里我调了2天,之前写的是i<=32000,然而我x++了,所以……
		tr[i]+=x;
}
int getsum(int q)
{
	int ans=0;
	for(int i=q;i>0;i-=lowbit(i))
		ans+=tr[i];
	return ans;
}//模板
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		int x,y;
		scanf("%d%d",&x,&y);
		x++;//为了防止x为0
		update(x,1);
		ans[getsum(x)-1]++;//前面x++了,后边要减回来
	}
	for(int i=0;i<n;i++)
		printf("%d\n",ans[i]);
}

                                                                                                                                            By WZY




  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值