PAT甲级——1146 Topological Order (25分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

      
    

Sample Output:

3 4

第一次写拓扑序列的题目:

柳婼的解法,带我自己的注解的版本~

#include <iostream>
#include <vector>

using namespace std;

int main() {
    int n,m,k,a,b,in[1010],flag = 0;
    vector<int> v[1010]; //定义二维数组v[1010][]
    scanf("%d %d", &n, &m);
    for(int i = 0; i < m; i++) //m 行边关系
    {
        scanf("%d %d",&a ,&b); //使用scanf存储边关系
        v[a].push_back(b); //将便关系写入vector数组v[1010][]中
        in[b]++; //入度数组加1
    }
    scanf("%d",&k); //接下来是k个拓扑序列
    for(int i=  0;i < k; i++)
    {
        int judge = 1;  //首先预设是正确的序列
        vector<int> tin(in, in+n+1); //使用vector tin 复制入度序列 in[]
        for(int j = 0;j < n;j++) //
        {
            scanf("%d", &a);  //输入需要测试的顶点
            if (tin[a] != 0) judge = 0; //如果入度不为0 ,则为假
            for (int it : v[a]) tin[it]--;  //将该点对应的入度减去1 ;其实是遍历v[a][]这一行的序列
        }
        if (judge == 1) continue;
        printf("%s%d", flag == 1 ? " ": "", i);
        flag = 1;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

陈沧夜

打个赏,让我买瓶可乐喝呗~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值