poj 3684(物理题 小球弹性碰撞问题)

Physics Experiment

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3957 Accepted: 1407 Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20

N个小球从H高的高度往下落  每一秒落下一个小球  (小球可以和小球互相弹性碰撞  和地面弹性碰撞) 问最后每个小球与地面的高度。

解决小球相撞的问题:小球互相装可以不用考虑  和poj1852的思路是一样的

 

这题是挑战程序设计上面的题

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>

using namespace std;
const int N=200;
double y[N];
int n;
double h,r,t;
double calc(double T)
{
	if(T<0) return h;
	double tt=sqrt(2*h/10.0);
	int k=(int)(T/tt);//看一下T能有几个tt的时间 
	
	if(k%2==0){//如果k是偶数说明还是从上往下落 把中间来回落的省去 
		double d=T-k*tt;
		return h-10.0*d*d/2; 
	} 
	else{//奇数的话 那么就是从小往上去的小球  
		double d=k*tt+tt-T;//改变层为偶数相当于从上开始往下落 
		return h-10.0*d*d/2;
	}
	
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d %lf %lf %lf",&n,&h,&r,&t);
		for(int i=0;i<n;i++){
			y[i]=calc(t-i);
		}
		sort(y,y+n);
		for(int i=0;i<n;i++){
			printf("%.2f%c",y[i]+2*r*i/100,i+1==n?'\n':' ');
		}
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值