【hdu1501】zipper——dfs

该博客介绍了如何利用深度优先搜索(DFS)策略解决HDU1501 'Zipper'问题。题目要求确定两个字符串是否能合并成第三个字符串。由于存在两种选择(来自输入字符串a或b),记忆化搜索方法被采用,通过二维数组记录状态。博客详细讲解了三种可能的情况:两个都可行、仅一个可行以及都不行,并提供了相应的代码实现。
摘要由CSDN通过智能技术生成

题目:

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8645    Accepted Submission(s): 3061


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1502  1227  1158  1080  1503 

描述:给两个字符串,问能否归并成第三个字符串

题解:用一个二维数组来记录是否枚举过某个情况。由于存在a,b两个数组的某一个元素都可以去放在第三个数组相同值元素的位置,所以不能用队列,要dfs记忆化搜索,分三种情况,两个都行的,其中一个行一个不行的。

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <queue>
using namespace std;
char a[500], b[500], c[500];
int vis[220][220];
bool ans = false;
void init()
{
	memset(vis, 0, sizeof(vis));
	ans = false;
}

void dfs(int i, int j, int k)
{
	if (vis[i][j])
		return;
	vis[i][j] = 1;
	if (c[k] == '\0')
	{
		ans = true;
		return;
	}
	if (a[i] == c[k] && b[j] == c[k])
	{
		dfs(i + 1, j, k + 1);
		//vis[i + 1][j] = 0;                   //由于是点对来标记,其实不需要回溯,因为这个点不会再被跑到了
		dfs(i, j + 1, k + 1);
	}
	else if (a[i] == c[k] && b[j] != c[k])
		dfs(i + 1, j, k + 1);
	else if (a[i] != c[k] && b[j] == c[k])
		dfs(i, j + 1, k + 1);
	else
		return;
}

int main()
{
	//freopen("input.txt", "r", stdin);
	int T, cnt = 1;
	cin >> T;
	while (T--)
	{
		scanf("%s%s%s", a, b, c);

		init();
		dfs(0, 0, 0);
		if (ans)
			printf("Data set %d: yes\n", cnt++);
		else
			printf("Data set %d: no\n", cnt++);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值