J - A Bug‘s Life(加权并查集)

J - A Bug’s Life

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

加权并查集: 有的时候,不仅需要像普通并查集一样记录一些元素之间有无关系,还需要记录它们之间有怎样的关系,这时候就需要引入加权并查集。 通常情况下,用一个数组r来记录这些关系,r[i]表示元素i与父结点的关系。至于是什么关系,还要根据具体要求来看。 在find(x)函数中进行路径压缩的同时,许多结点的父结点会改变,这时就需要根据实际情况调整权值以保证其正确性。 在union(x,y)函数中,(不妨设将y集合并入x集合)由于y的父结点的改变,需要调整y对应的权值,但不需要调整y的子结点对应的权值,因为子结点 权值会在find(子结点)时得到调整。
代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pre[20010];
int r[20010];//r=0代表与根节点同性
int Find(int x)
{
    int t;
    if(pre[x]==x)
    {
        return x;
    }
    t=pre[x];
    pre[x]=Find(pre[x]);//压缩路径
    r[x]=(r[x]+r[t]+1)%2;
    return pre[x];
}
void Union(int a,int b)
{
    int x,y;
    x=Find(a);
    y=Find(b);
    pre[x]=y;
    r[x]=(r[b]-r[a])%2;
}
int main()
{
    int t,i,j,k,flag;
    int n,m,a,b;
    scanf("%d",&t);
    for(k=1; k<=t; k++)
    {
        flag=0;
        scanf("%d%d",&n,&m);
        for(i=1; i<=n; i++)
        {
            r[i]=1;
            pre[i]=i;
        }
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            if(Find(a)==Find(b))
            {
                if(r[a]==r[b])//同性
                {
                    flag=1;
                }
            }
            else
            {
                Union(a,b);
            }
        }
        if(flag)
        {
            printf("Scenario #%d:\nSuspicious bugs found!\n\n",k);
        }
        else
        {
            printf("Scenario #%d:\nNo suspicious bugs found!\n\n",k);
        }
    }
    return 0;
}

作者:王陸
出处:https://www.cnblogs.com/wkfvawl/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值