POJ 1995 Raising Modulo Numbers

Raising Modulo Numbers
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6648 Accepted: 3958

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bifrom all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195

13

有的人爱看片儿、有的人爱在地窖里造原子弹、有的人爱用Windows,我爱计算(A1B1+A2B2+ … +AHBH)mod M,微笑真的不是很懂你们出题人。纯快速幂。为什么32位机用long long老是各种毛病?__int64就没事,但是某个OJ不能用__int64,搞得我现在只敢用long long了,这次干脆不输出了,找了半天没有bug,改成__int64一切正常。然后交了。直接AC。百思不得其姐姐。

#include<stdio.h>
long long fff(long long x,long long y,long long z)
{
	long long ans=1;
	x=x%z;
	while(y)
	{
		if(y%2==1)
		ans=(ans*x)%z;
		x=(x*x)%z;
		y=y/2;
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	long long i,m,n,a,b,ans;
	while(t--)
	{	
		ans=0;
		scanf("%lld%lld",&m,&n);
		for(i=0;i<n;i++)
		{
			scanf("%lld%lld",&a,&b);
			ans=(ans+fff(a,b,m))%m;
		}
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值