UVa 12169 Disgruntled Judge(扩展欧几里得算法的应用)

5 篇文章 0 订阅
5 篇文章 0 订阅

12169 - Disgruntled Judge


Time limit: 3.000 seconds   

    Once upon a time, there was an NWERC judge with a tendency to create slightly too hard problems. As a result, his problems were never solved. As you can image, this made our judge somewhat frustrated.This year, this frustration has culminated, and he has decided that rather than spending a lot of time constructing a well-crafted problem, he will simply write some insanely hard problem statement and just generate some random input and output les. After all, why bother having proper test data if nobody is going to try the problem anyway?Thus, the judge generates a test case by simply letting the input be a random number, and letting the output be another random number. Formally, to generate the data set with T test cases, the judge generates 2T random numbers between 0 and 10 000, and then writes T, followed by these quence  to the input le, and the sequence  to the output le. The random number generator the judge uses is quite simple. He picks three numbers , a, and b between 0 and 10 000 (inclusive), and then for i from 2 to 2T lets  You may have thought that such a poorly designed problem would not be used in a contest of such high standards as NWERC. Well, you were wrong.

Input
       On the rst line one positive number: the number of test cases, at most 100. After that per test case:

       • One line containing an integer n (0 ≤ n ≤ 10000): an input test case.
        The input le is guaranteed to be generated by the process described above.
Output

Per test case:

     • One line with an integer giving the answer for the test case.

     If there is more than one output le consistent with the input le, any one of these is acceptable.

Sample Input

3

17

822

3014

Sample Output

9727

1918

4110


       ps: 枚举A的值[0, 10000](因为地推公式按10001取模, 如果大于10000就会重复之前的现象。比如:0和10001,用递推公式推出来的值都是一样的)。因为:

        
         整理为:
            
        从而将问题转换为扩展欧几里得算法的问题(扩展欧几里得算法戳我),求出b,然后根据递推公式判断是否符合原来的数列,如果不符合说明不是这个数列的解。

#include<iostream>
#define ll long long
using namespace std;
void ex_gcd(ll a, ll b, ll &d, ll &x, ll &y)
{//扩展欧几里得算法
    if (!b)
        {d = a; x = 1; y = 0;}

    else
    {
        ex_gcd(b, a % b, d, y, x);
        y -= x * (a / b);
    }
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    ll T;
    ll _in[105];//保存原来x1,x3...x(2T-1)的数组
    ll ans[205];//保存结果
    while(cin>>T)
    {
        bool flag = 1;
        for(int i = 0; i < T; i++)cin>>_in[i];
        ans[0] = _in[0];
        int index = 1;
        for(int a = 0; a <= 10000; a++)
        {
            //Ax + By = C
            ll c = _in[1] - a * a * _in[0]; //C
            ll _a = a + 1;//A
            ll b = -10001;//B
            ll d, _x, _y;
            ex_gcd(_a, b, d, _x, _y);
            if(c % d)continue;
                ll x = _x * (c / d);
            for(int i = 1; i < 2 * T; i++)
            {
                ans[i] = (a * ans[i - 1] + x) % 10001;
                if(i % 2 == 0)
                {
                    if(_in[index] == ans[i]){
                        flag = 1;
                        index++;
                    }
                    else {
                        flag = 0;
                        index = 1;
                        break;
                    }
                }
            }
            if(flag){
                break;
            }
        }
        for(int i = 1; i < 2 * T; i += 2)
        {
            cout<<ans[i]<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值