Wooden Sticks

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u  

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
题意:
    给定一堆带有长度和重量的物品,第一个物品需要一台机器,如果之后的物品的长度和重量都大于等于第之前某物品,那就不需要增加机器,问最多需要的机器量。
思路:
    这道题对机器的长度排序,然后只需要关注重量,求反链(最大递减子序列)
//
// Create by Running Photon on 2015-03-14
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <iomanip>
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
using namespace std;

#define CLR(x) memset(x,0,sizeof x)
#define ll long long
const int inf=0x3f3f3f3f;
const int maxn=5e3+5;
const int MOD=5e5+5;
int t, n;
int dp[maxn];
struct acm
{
    int l, r;
    bool operator < (const acm & th)const{
        return l < th.l || l == th.l && r < th.r;
    }
}num[maxn];
int main()
{
#ifdef LOCAL
freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
#endif
ios_base::sync_with_stdio(0);

scanf("%d", &t);
while(t--){
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
            scanf("%d%d", &num[i].l, &num[i].r);
        sort(num + 1, num + 1 + n);
        int ans = 0;
        CLR(dp);
        dp[0] = inf;
        for(int i = 1; i <= n; i++){
            if(dp[ans] > num[i].r) dp[++ans] = num[i].r;
            int l = 1, r = ans;
            while(l <= r){
                int mid = (l + r) / 2;
                if(dp[mid] > num[i].r) l = mid + 1;
                else r = mid - 1;
            }
            dp[l] = num[i].r;
        }
        printf("%d\n", ans);
}

return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值