Fliping game HDU - 4642

7 篇文章 0 订阅
2 篇文章 0 订阅
Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x  1, y  1)-(n, m) (1 ≤ x  1≤n, 1≤y  1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x 1≤x≤n, y  1≤y≤m)). The only restriction is that the top-left corner (i.e. (x  1, y 1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.
Input
The first line of the date is an integer T, which is the number of the text cases. 
Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.
Output
For each case, output the winner’s name, either Alice or Bob.
Sample Input
2
2 2
1 1
1 1
3 3
0 0 0
0 0 0
0 0 0
Sample Output
Alice
Bob
 
 
 
 
找一找就有规律了。
#include <cstdio>
int main() {
	int N;
	scanf("%d",&N);
	while(N--) {
		int n , m , a;
		scanf("%d %d",&n , &m);
		for(int i = 0; i < n; i++)
		for(int j = 0; j < m; j++)
		scanf("%d",&a);
		if(a) puts("Alice");
		else puts("Bob");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值