HDU 4430 Yukari's Birthday

Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl. 
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k  i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r. 
Input
There are about 10,000 test cases. Process to the end of file. 
Each test consists of only an integer 18 ≤ n ≤ 10  12
Output
For each test case, output r and k.
Sample Input
18
111
1111
Sample Output
1 17
2 10
3 10
题意: 给出n,让n满足下列表达式:k^1+k^2+...+k^r=n(等于n-1也可以). 且r*k要最小,输出r和k,如果有多组条件满足,就输出r最小的一组。

因为k比较大,所以我们可以二分查找k,然后枚举r就可以解决问题了。

#include <stdio.h>
#include <string.h>
#define ll long long
ll n;
ll cal(int x, ll m) {
    ll sum = 0, s = 1;
    for(int i = 1; i <= x; i++) {
        if(n/s < m) {
            sum = n+1;
            break;
        }
        sum += s*m;
        s *= m;
        if(sum > n) break;
    }
    return sum;
}
ll solve(int x) {
    ll left = 2, right = n, mid;
    while(left <= right) {
        mid = left-(left-right)/2;
        ll sum = cal(x, mid);
        if(sum == n || sum == n-1)
            return mid;
        else if(sum < n-1) left = mid+1;
        else right = mid-1;
    }
    return 0;
}
int main() {
    while(~scanf("%lld", &n)) {
        ll rl = 1, rr = n-1;
        for(int i = 2; i <= 45; i++) {
                ll s = solve(i);
            if(s && i*s < rl*rr) {
                rl = i;
                rr = s;
            }
        }
        printf("%lld %lld\n", rl, rr);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值