Vitaly and Night

Problem:Vitaly and Night

Description:
One day Vitaly was going home late at night and wondering: how many people aren’t sleeping at that moment? To estimate, Vitaly decided to look which windows are lit in the house he was passing by at that moment.
Vitaly sees a building of n floors and 2·m windows on each floor. On each floor there are m flats numbered from 1 to m, and two consecutive windows correspond to each flat. If we number the windows from 1 to 2·m from left to right, then the j-th flat of the i-th floor has windows 2·j - 1 and 2·j in the corresponding row of windows (as usual, floors are enumerated from the bottom). Vitaly thinks that people in the flat aren’t sleeping at that moment if at least one of the windows corresponding to this flat has lights on.
Given the information about the windows of the given house, your task is to calculate the number of flats where, according to Vitaly, people aren’t sleeping.

Input:
The first line of the input contains two integers n and m (1 ≤ n, m ≤ 100) — the number of floors in the house and the number of flats on each floor respectively.
Next n lines describe the floors from top to bottom and contain 2·m characters each. If the i-th window of the given floor has lights on, then the i-th character of this line is ‘1’, otherwise it is ‘0’.

Output:
Print a single integer — the number of flats that have lights on in at least one window, that is, the flats where, according to Vitaly, people aren’t sleeping.

Sample Input 1:
2 2
0 0 0 1
1 0 1 1

Sample Output 1:
3

Sample Input 2:
1 3
1 1 0 1 0 0

Sample Output 2:
2

Note:
In the first test case the house has two floors, two flats on each floor. That is, in total there are 4 flats. The light isn’t on only on the second floor in the left flat. That is, in both rooms of the flat the light is off.
In the second test case the house has one floor and the first floor has three flats. The light is on in the leftmost flat (in both windows) and in the middle flat (in one window). In the right flat the light is off.

Language:C

#include <stdio.h>

int main()
{
  int n,m;
  int i;
  int count=0;
  int left,right;
  scanf("%d%d",&n,&m);
  while(n--)
  {
    for(i=0;i<m;i++)
    {
      scanf("%d%d",&left,&right);

      if(left==1||right==1) count++;
    }
  }
  printf("%d\n",count);

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值