Perfect Permutation

Problem:Perfect Permutation

Description:
A permutation is a sequence of integers p1, p2, …, pn, consisting of n distinct positive integers, each of them doesn’t exceed n. Let’s denote the i-th element of permutation p as pi. We’ll call number n the size of permutation p1, p2, …, pn.
Nickolas adores permutations. He likes some permutations more than the others. He calls such permutations perfect. A perfect permutation is such permutation p that for any i (1 ≤ i ≤ n) (n is the permutation size) the following equations hold ppi = i and pi ≠ i. Nickolas asks you to print any perfect permutation of size n for the given n.

Input:
A single line contains a single integer n (1 ≤ n ≤ 100) — the permutation size.

Output:
If a perfect permutation of size n doesn’t exist, print a single integer -1. Otherwise print n distinct integers from 1 to n, p1, p2, …, pn — permutation p, that is perfect. Separate printed numbers by whitespaces.

Sample Input 1:
1

Sample Output 1:
-1

Sample Input 2:
2

Sample Output 2:
2 1

Sample Input 3:
4

Sample Output 3:
2 1 4 3

Language:C

# include <stdio.h>
int main()
{
  int n;
  int i;
  scanf("%d",&n);
  if(n%2) printf("-1");
  else
  {
    for(i=1;i<=n;i+=2)
    {
      printf("%d %d ",i+1,i);
    }
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值