Equidistant String

Problem:Equidistant String

Description:
Little Susie loves strings. Today she calculates distances between them. As Susie is a small girl after all, her strings contain only digits zero and one. She uses the definition of Hamming distance:
We will define the distance between two strings s and t of the same length consisting of digits zero and one as the number of positions i, such that si isn’t equal to ti.
As besides everything else Susie loves symmetry, she wants to find for two strings s and t of length n such string p of length n, that the distance from p to s was equal to the distance from p to t.
It’s time for Susie to go to bed, help her find such string p or state that it is impossible.

Input:
The first line contains string s of length n.
The second line contains string t of length n.
The length of string n is within range from 1 to 105. It is guaranteed that both strings contain only digits zero and one.

Output:
Print a string of length n, consisting of digits zero and one, that meets the problem statement. If no such string exist, print on a single line “impossible” (without the quotes).
If there are multiple possible answers, print any of them.

Sample Input 1:
0001
1011

Sample Output 1:
0011

Sample Input 2:
000
111

Sample Output 2:
impossible

Note:
In the first sample different answers are possible, namely — 0010, 0011, 0110, 0111, 1000, 1001, 1100, 1101.

Language:C

#include <stdio.h>
#include <string.h>

int main()
{
  char s1[100010],s2[100010];
  scanf("%s%s",s1,s2);
  int n=strlen(s1);
  int i;
  int count=0;
  for(i=0;i<n;i++)
  {
    if(s1[i]!=s2[i])
    {
      count++;
    }
  }

  if(count%2)
  {
    printf("impossible");
  }
  else
  {
    count/=2;
    for(i=0;i<n;i++)
    {
      if(s1[i]!=s2[i])
      {
        s1[i]=s2[i];
        count--;
      }
      if(count==0) break;
    }
    puts(s1);
  }

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值