HDU 1002 高精度 大数据加法

一条很简单的大数据加法题,题意简单明了
题目:

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 187987    Accepted Submission(s): 35894


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
代码:
#include<stdio.h>
#include<string.h>
void main()
{
	int n,i,j,c[1002],d[1002],e[1002],l1,l2,l,x;
	char a[1002],b[1002];
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		for(j=0;j<1002;j++)
		{
			a[j]='0';
			b[j]='0';
			c[j]=0;
			d[j]=0;
			e[j]=0;
		}
		scanf("%s %s",a,b);
		l1=strlen(a);
		l2=strlen(b);
		l=l1>l2 ? l1:l2;
		x=0;
		for(j=l1-1;j>=0;j--)
		{
			c[j]+=a[x++]-'0';	
		}
		x=0;
		for(j=l2-1;j>=0;j--)
		{
			d[j]+=b[x++]-'0';
		}
		for(j=0;j<l;j++)
		{
			e[j]=c[j]+d[j];
		}
		for(j=0;j<l;j++)
		{
			if(e[j]>9)
			{
				e[j]-=10;
				e[j+1]++;
			}
		}
		if(e[l]!=0)
			l++;
		printf("Case %d:\n",i+1);
		printf("%s + %s = ",a,b);
		for(j=l-1;j>=0;j--)
			printf("%d",e[j]);
		if(i!=n-1)
			printf("\n\n");
		else
			printf("\n");
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值