King Arthur's Knights —— 结题报告!

http://acm.hdu.edu.cn/showproblem.php?pid=4337

King Arthur's Knights

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Special Judge

Problem Description
I am the bone of my sword. Steel is my body, and the fire is my blood.
- from Fate / Stay Night
You must have known the legend of King Arthur and his knights of the round table. The round table has no head, implying that everyone has equal status. Some knights are close friends with each other, so they prefer to sit next to each other.

Given the relationship of these knights, the King Arthur request you to find an arrangement such that, for every knight, his two adjacent knights are both his close friends. And you should note that because the knights are very united, everyone has at least half of the group as his close friends. More specifically speaking, if there are N knights in total, every knight has at least (N + 1) / 2 other knights as his close friends.

Input
The first line of each test case contains two integers N (3 <= N <= 150) and M, indicating that there are N knights and M relationships in total. Then M lines followed, each of which contains two integers ai and bi (1 <= ai, bi <= n, ai != bi), indicating that knight ai and knight bi are close friends.

Output
For each test case, output one line containing N integers X1, X2, ..., XN separated by spaces, which indicating an round table arrangement. Please note that XN and X1 are also considered adjacent. The answer may be not unique, and any correct answer will be OK. If there is no solution exists, just output "no solution".

Sample Input
  
  
3 3 1 2 2 3 1 3 4 4 1 4 2 4 2 3 1 3

Sample Output
  
  
1 2 3 1 4 2 3

Source

Recommend
zhoujiaqi2010

 

其他大牛的结题报告,我到略看了下。

http://www.cnblogs.com/jiai/archive/2012/08/03/2621040.html

http://blog.sina.com.cn/s/blog_6ffc3bde01012lyj.html
看了大牛的结题报告,说是深搜,再略看了下,就自己敲了下。敲的途中,没看正确 的 结题报告,一路敲下来。样例过了,提交了几次,也wa 了几次,原因也找到了。


题目会做,就觉得不过如此,一个深搜,根本是是H图。

happy中!

加油↖(^ω^)↗!

 

//King Arthur's Knights
#include <cstdio>
#include <cstring>
#include <vector>
#include <iostream>
#include <cstdio>
using namespace std;

vector <vector <int> >g;

int a[200];
int pos;
int n, m;
bool use[200];

void init()
{
    g.clear();
    g.resize(n + 1);
    pos = 0;
    memset(use, false, sizeof (use));
}

bool f(int x)
{
    if (pos == n)
    {
        for (int j = g[1].size() - 1; j >= 0; j--)
            if (g[1][j] == x)
                return true;
        return false;
    }
    else
    {
        for (int j = g[x].size() - 1; j >= 0; j--)
        {
            if ( !use[ g[x][j] ])
            {
                use[ g[x][j]] = true;
                a[pos++] =  g[x][j];

                if (f( g[x][j]  ))
                    return true;
                else
                {
                    use[ g[x][j]] = false;
                    pos--;
                }
            }
        }
        return false;
    }


}

int main()
{
    while (cin >> n >> m)
    {
        init();
        {
            int u, v;
            for (int j = 0; j < m; j++)
            {
                scanf("%d%d", &u, &v);
                g[u].push_back(v);
                g[v].push_back(u);
            }

            pos = 1;
            use[1] = true;
            if (f(1))
            {
                printf("1");
                for(int j = 1; j < n; j++)
                    printf(" %d", a[j]);
                printf("\n");
            }
            else
                printf("no solution\n");
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值