图的m着色问题
Description
图的m 着色问题描述如下:给定无向连通图G 和m 种不同的颜色。用这些颜色为图G的各顶点着色,每个顶点着一种颜色。如果有一种着色法使G 中每条边的2 个顶点着不同颜色,则称这个图是m 可着色的。图的m着色问题是对于给定图G和m 种颜色,找出所有不同的着色法。
编程任务:
对于给定的无向连通图G 和m种不同的颜色,编程计算图的所有不同的着色法。
Input
输入由多组测试数据组成。
每组测试数据输入的第一行有3 个正整数n,k 和m,表示给定的图G 有n个顶点和k条边,m种颜色。顶点编号为1,2,…,n。 接下来的k行中,每行有2个正整数u,v,表示图G 的一条边(u,v)。
Output
对应每组输入,输出的每行是计算出的不同的着色方案数。
Sample Input
5 8 4
1 2
1 3
1 4
2 3
2 4
2 5
3 4
4 5
Sample Output
48
Source
搜索回溯,贪心
Solution
直接遍历图中的每一个点,用f[i][j]记录第i个点染第j种颜色的方案数
对于每一个点枚举所能染的每一种颜色,然后更新与之相连的点,继续递归搜索
回溯的时候把所有与之相连的点染当前颜色的方案数-1即可,每次搜完n个点ans++并返回
Code
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <map>
#include <vector>
#include <queue>
#define L 1010
#define LL long long
using namespace std;
int n, k, m, a, b, d[L][L], ans, f[L][L];
inline void dfs(int x) {
if(x == n + 1) {ans++; return ;}
for (int i = 1; i <= m; ++i)
if (!f[x][i]) {
for (int j = 1; j <= n; ++j)
if (d[x][j]) f[j][i]++;
dfs(x + 1);
for (int j = 1; j <= n; ++j)
if (d[x][j]) f[j][i]--;
}
}
int main() {
freopen("2028.in", "r", stdin);
freopen("2028.out", "w", stdout);
scanf("%d %d %d", &n, &k, &m);
for (int i = 1; i <= k; ++i) {
scanf("%d %d", &a, &b);
d[a][b] = 1, d[b][a] = 1;
}
dfs(1);
printf("%d\n", ans);
return 0;
}