POJ 1679 The Unique MST

POJ 1679 The Unique MST

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

POJ Monthly--2004.06.27 srbga@POJ

Solution

判断最小生成树是否唯一:先求一遍最小生成树,并将之记录,枚举次小生成树比较二者是否一样,如果一样(包括大小以及组成元素的个数)则最小生成树不唯一

求次小生成树这里我用的是暴力枚举,直接枚举次小生成树中可能与最小生成树中不同顺序的点,如果有不同顺序的点但大小和元素个数仍不相同,那么最小生成树就不唯一

Code

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <map>
#include <vector>
#include <queue>
#define L 110
#define LL long long
using namespace std;

struct node{
  int x, y, d;
} e[L * L];
int t, n, m, fa[L], ans, cnt, a[L], tot, sum;
bool flag;

inline bool comp (node a, node b) {
  return a.d < b.d;
}

inline int findfa (int x) {
  if (x != fa[x]) return fa[x] = findfa(fa[x]);
  return x;
}

int main() {
  freopen("1679.in", "r", stdin);
  freopen("1679.out", "w", stdout);
  scanf("%d", &t);
  while(t--) {
    scanf("%d %d", &n, &m);
    for (int i = 0; i < m; ++i) scanf("%d %d %d", &e[i].x, &e[i].y, &e[i].d);
    sort(e, e + m, comp);
    for (int i = 1; i <= n; ++i) fa[i] = i;
    ans = tot = 0;
    memset(a, 0, sizeof(a));
    for (int i = 0; i < m; ++i) {
      int u = findfa(e[i].x);
      int v = findfa(e[i].y);
      if (u != v) fa[u] = v, ans += e[i].d, a[tot++] = i;
    }
    flag = false;
    for (int i = 0; i < tot; ++i) {
      cnt = sum = 0;
      for (int j = 0; j < m; ++j)
	if (j != a[i]) sum += e[j].d, cnt++;
      if (tot == cnt && ans == sum){
	flag = true; break;
      }
    }
    if (flag) printf("Not Unique!\n");
    else printf("%d\n", ans);
  }
  return 0;
}

Solution

一开始写了很多没有用的判断,后面不停的优化到了0ms,但是开的数组较大


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值