1081 检查密码

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

C:

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	int l;
	char a[100];
	int i,j;
	int q,w,e;
	scanf("%d",&n);
	getchar();
	for(i=0;i<n;i++)
	{
		q=0;
		w=0;
		e=0;
		gets(a);
		l=strlen(a);
		if(l<6)
		    printf("Your password is tai duan le.\n");
		else
		{
			for(j=0;j<l;j++)
			{
				if(a[j]>='0'&&a[j]<='9')
				    q=1;
				else if(a[j]>='a'&&a[j]<='z'||a[j]>='A'&&a[j]<='Z')
				    w=1;
				else if(a[j]!='.')
				    e=1;	    
			}
			if(e==1)
                printf("Your password is tai luan le.\n");
            else if(q==1&&w==0)
                printf("Your password needs zi mu.\n");
            else if(q==0&&w==1)
                printf("Your password needs shu zi.\n");
            else
                printf("Your password is wan mei.\n"); 
		}    
	}	
	return 0;
}

C++:

#include<iostream>
#include<string>
using namespace std;

int main() {
    int n;
    cin >> n;
    cin.ignore();
    while(n--) {
        string s;
        getline(cin, s);
        if(s.size() < 6) {
            cout << "Your password is tai duan le." << endl;
        } else {
            bool hasDigit = false, hasAlpha = false, hasInvalid = false;
            for(char c : s) {
                if(isdigit(c)) hasDigit = true;
                else if(isalpha(c)) hasAlpha = true;
                else if(c != '.') hasInvalid = true;
            }
            if(hasInvalid) cout << "Your password is tai luan le." << endl;
            else if(!hasAlpha) cout << "Your password needs zi mu." << endl;
            else if(!hasDigit) cout << "Your password needs shu zi." << endl;
            else cout << "Your password is wan mei." << endl;
        }
    }
    return 0;
}

Java:

import java.util.Scanner;

public class PasswordChecker {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        sc.nextLine();
        while(n-- > 0) {
            String s = sc.nextLine();
            if(s.length() < 6) {
                System.out.println("Your password is tai duan le.");
            } else {
                boolean hasDigit = false, hasAlpha = false, hasInvalid = false;
                for(char c : s.toCharArray()) {
                    if(Character.isDigit(c)) hasDigit = true;
                    else if(Character.isLetter(c)) hasAlpha = true;
                    else if(c != '.') hasInvalid = true;
                }
                if(hasInvalid) System.out.println("Your password is tai luan le.");
                else if(!hasAlpha) System.out.println("Your password needs zi mu.");
                else if(!hasDigit) System.out.println("Your password needs shu zi.");
                else System.out.println("Your password is wan mei.");
            }
        }
        sc.close();
    }
}

Python:

n = int(input())

for _ in range(n):
    s = input()
    if len(s) < 6:
        print("Your password is tai duan le.")
    else:
        hasDigit, hasAlpha, hasInvalid = False, False, False
        for c in s:
            if c.isdigit():
                hasDigit = True
            elif c.isalpha():
                hasAlpha = True
            elif c != '.':
                hasInvalid = True

        if hasInvalid:
            print("Your password is tai luan le.")
        elif not hasAlpha:
            print("Your password needs zi mu.")
        elif not hasDigit:
            print("Your password needs shu zi.")
        else:
            print("Your password is wan mei.")

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

向阳而生__

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值