1115 Counting Nodes in a Binary Search Tree

目录

Input Specification:

Output Specification:

Sample Input:

Sample Output:

C++:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

10
25 30 42 16 20 20 35 -5 28 22

Sample Output:

3 + 4 = 7

C++:

#include <bits/stdc++.h>
using namespace std;

int n,cnt[1010],max_depth;
map<double,int> v,f;

void insert(double root,int data,int depth)
{
	if(f[root]==0)
	{
		f[root]=1;
		max_depth=max(max_depth,depth);
		cnt[depth]++;
		v[root]=data;
		return ;
	}
	if(v[root]>=data&&f[root]==1)
	{
		insert(2*root,data,depth+1);
	}
	else if(v[root]<data&&f[root]==1)
	{
		insert(2*root+1,data,depth+1);
	}
}

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		int data;
		scanf("%d",&data);
		insert(0.00001,data,0);
	}
	printf("%d + %d = %d\n",cnt[max_depth],cnt[max_depth-1],cnt[max_depth-1]+cnt[max_depth]);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
Counting Supports of Candidates Using Hash Tree”是一种利用哈希树来计算候选项集支持度的方法。以下是一个简单的例子,说明如何使用哈希树来计算候选项集的支持度。 假设我们有一个包含以下事务的数据集: ``` t1: {1, 2, 3, 4} t2: {1, 2, 4, 5} t3: {2, 4, 5} t4: {1, 2, 3, 4, 5} ``` 我们要计算每个2项集的支持度。首先,我们需要生成所有的2项集: ``` {1, 2} {1, 3} {1, 4} {1, 5} {2, 3} {2, 4} {2, 5} {3, 4} {3, 5} {4, 5} ``` 接下来,我们可以使用哈希树来计算每个2项集的支持度。首先,对于每个项集,我们将其插入到哈希树中。具体地,从根节点开始,对于每个项集中的元素,根据哈希函数计算其子节点的位置,并将项集插入到相应的节点中。例如,对于项集{1, 2},我们需要依次插入到根节点、子节点1和子节点2中。最终,我们得到以下哈希树: ``` {} / | | \ 1 2 3 4 /| | | \ 2 3 4 5 5 / | | | 3 4 5 4 ``` 在计算支持度时,我们只需要遍历哈希树的叶子节点,找到包含在每个事务中的项集,并增加其计数器的值。例如,当处理事务t1时,我们需要遍历项集{1, 2}、{1, 3}、{1, 4}和{2, 3},并增加其计数器的值。最终,我们得到每个2项集的支持度: ``` {1, 2}: 3 {1, 3}: 1 {1, 4}: 2 {1, 5}: 1 {2, 3}: 2 {2, 4}: 3 {2, 5}: 2 {3, 4}: 2 {3, 5}: 2 {4, 5}: 2 ``` 这就是使用哈希树来计算候选项集支持度的简单示例。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

向阳而生__

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值