对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?
,最长对称子串为s PAT&TAP s
,于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:
Is PAT&TAP symmetric?
输出样例:
11
代码:
#include <bits/stdc++.h>
using namespace std;
const int N=60;
string str;
int res=1;
int main()
{
getline(cin,str);
int len=str.size();
for(int i=0;i<len;i++)
{
int x=0,y=0;
while(i-x>=0&&i+x<len&&str[i-x]==str[i+x])
{
x++;
}
while(i-y>=0&&i+y+1<len&&str[i-y]==str[i+y+1])
{
y++;
}
res=max({res,2*(x-1)+1,2*y});
}
printf("%d\n",res);
return 0;
}