将一系列给定数字顺序插入一个初始为空的小顶堆H[]
。随后判断一系列相关命题是否为真。命题分下列几种:
x is the root
:x
是根结点;x and y are siblings
:x
和y
是兄弟结点;x is the parent of y
:x
是y
的父结点;x is a child of y
:x
是y
的一个子结点。
输入格式:
每组测试第1行包含2个正整数N
(≤ 1000)和M
(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N
个要被插入一个初始为空的小顶堆的整数。之后M
行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式:
对输入的每个命题,如果其为真,则在一行中输出T
,否则输出F
。
输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
代码:
#include <bits/stdc++.h>
using namespace std;
const int N=1010;
int n,m,v[N];
map<int,int> pos;
void insert(int i)
{
while(i!=1&&v[i]<v[i/2])
{
swap(v[i],v[i/2]);
i=i/2;
}
}
int main()
{
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
{
scanf("%d",&v[i]);
insert(i);
}
for(int i=1;i<=n;i++)
{
pos[v[i]]=i;
}
getchar();
while(m--)
{
string str;
getline(cin,str);
if(str.find("root")!=-1)
{
int x;
sscanf(str.c_str(),"%d is the root",&x);
if(pos[x]==1)
{
printf("T\n");
}
else
{
printf("F\n");
}
}
else if(str.find("siblings")!=-1)
{
int x,y;
sscanf(str.c_str(),"%d and %d are siblings",&x,&y);
if(pos[x]/2==pos[y]/2)
{
printf("T\n");
}
else
{
printf("F\n");
}
}
else if(str.find("parent")!=-1)
{
int x,y;
sscanf(str.c_str(),"%d is the parent of %d",&x,&y);
if(pos[x]==pos[y]/2)
{
printf("T\n");
}
else
{
printf("F\n");
}
}
else if(str.find("child")!=-1)
{
int x,y;
sscanf(str.c_str(),"%d is a child of %d",&x,&y);
if(pos[x]/2==pos[y])
{
printf("T\n");
}
else
{
printf("F\n");
}
}
}
return 0;
}