L2-012 关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

代码:

#include <bits/stdc++.h>
using namespace std;

const int N=1010;

int n,m,v[N];
map<int,int> pos;

void insert(int i)
{
	while(i!=1&&v[i]<v[i/2])
	{
		swap(v[i],v[i/2]);
		i=i/2;
	}
}

int main()
{
	scanf("%d %d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&v[i]);
		insert(i);
	}
	for(int i=1;i<=n;i++)
	{
		pos[v[i]]=i;
	}
	getchar();
	while(m--)
	{
		string str;
		getline(cin,str);
		if(str.find("root")!=-1)
		{
			int x;
			sscanf(str.c_str(),"%d is the root",&x);
			if(pos[x]==1)
			{
				printf("T\n");
			}
			else
			{
				printf("F\n");
			}
		}
		else if(str.find("siblings")!=-1)
		{
			int x,y;
			sscanf(str.c_str(),"%d and %d are siblings",&x,&y);
			if(pos[x]/2==pos[y]/2)
			{
				printf("T\n");
			}
			else
			{
				printf("F\n");
			}
		}
		else if(str.find("parent")!=-1)
		{
			int x,y;
			sscanf(str.c_str(),"%d is the parent of %d",&x,&y);
			if(pos[x]==pos[y]/2)
			{
				printf("T\n");
			}
			else
			{
				printf("F\n");
			}
		}
		else if(str.find("child")!=-1)
		{
			int x,y;
			sscanf(str.c_str(),"%d is a child of %d",&x,&y);
			if(pos[x]/2==pos[y])
			{
				printf("T\n");
			}
			else
			{
				printf("F\n");
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

向阳而生__

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值