【PAT刷题甲级】1133.Splitting A Linked List

1133 Splitting A Linked List (25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10 ^5 ) which is the total number of nodes, and a positive K (≤10 ^3 ). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10 ^5 ,10 ^5 ], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

题意

按照地址遍历数字,要求负数排在前面,然后排[0,k]范围内的数字,最后排剩下的数字。
PS:使用到合并vector的相关语法。

vector<int> v1,v2,v3;
//v1,v2非空
v3.insert(v3.end(),v1.begin(),v1.end());	//在v3末尾插入v1
v3.insert(v3.end(),v2.begin(),v2.end());	//在v3末尾插入v2

另:输出方式有参照柳神
自己的写法总有2个点过不了,不懂为什么。

	for(int i=1;i<n;i++){	//自己的写法,测试点2,4答案错误
		printf("%05d %d %05d\n",res[i-1],Node[res[i-1]].data,res[i]);
		if(i==n-1)	printf("%05d %d -1",res[i],Node[res[i]].data);
	} 

还有在遍历 res 时,使用 i<n 会显示测试点2,4答案错误,但是改成 i<res.size() 会只显示测试点2错误,测试点4正确。我寻思着这俩不是一样吗,想不通,希望看到的大神能指点一下。

代码

#include <iostream>
#include <vector>
using namespace std;
struct node {
	int data,next;
} Node[100010];
vector<int> res,res2,res3;
int main() {
	int st,n,k;
	scanf("%d%d%d",&st,&n,&k);
	int a,b,c;
	for(int i=0; i<n; i++) {
		scanf("%d%d%d",&a,&b,&c);
		Node[a].data=b;
		Node[a].next=c;
	}
	int j=st;
	while(j!=-1) {
		int data=Node[j].data;
		if(data<0)	res.push_back(j);
		else if(data>=0 && data<=k)	res2.push_back(j);
		else	res3.push_back(j);
		j=Node[j].next;
	}
	res.insert(res.end(),res2.begin(),res2.end());  //合并vector数组
	res.insert(res.end(),res3.begin(),res3.end());
	for(int i=0; i<res.size(); i++) {
		if(i==0)    printf("%05d %d ",res[i],Node[res[i]].data);
		else    printf("%05d\n%05d %d ",res[i],res[i],Node[res[i]].data);
	}
	printf("-1");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值