1133 Splitting A Linked List (25分)
Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤10^3). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer in [−10^5 ,10^5], and Next is the position of the next node. It is guaranteed that the list is not empty.
Output Specification:
For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1
题目大意及思路:
第一个为自己的地址adress,中间为数据data,最后为下一个结点的地址next。先把数据全部存储到a数组,然后按得链表顺序存储到b数组,最后先循环一遍b数组找到小于零的数放进v[ ],在循环第二遍找到大于零的数小于k的数放进v[ ],最后再循环一遍找到大于k的数放进v[ ]。
代码:
#include<stdio.h>
typedef struct Node{
int adress;
int data;
int next;
}node;
node a[100010],b[100010],v[100010];
int main(){
int n,start,k,j=0;
scanf("%d%d%d",&start,&n,&k);
for(int i=0;i<n;i++){
int ads,data,next;
scanf("%d%d%d",&ads,&data,&next);
a[ads].adress=ads;
a[ads].data=data;
a[ads].next=next;
}
while(start!=-1){
b[j].adress=a[start].adress;
b[j].data=a[start].data;
b[j].next=a[start].next;
start=a[start].next;
j++;
}
int t=j;
j=0;
for(int i=0;i<t;i++){
if(b[i].data<0){
v[j].adress=b[i].adress;
v[j].data=b[i].data;
v[j++].next=b[i].next;
}
}
for(int i=0;i<t;i++){
if(b[i].data>=0 && b[i].data<=k){
v[j].adress=b[i].adress;
v[j].data=b[i].data;
v[j++].next=b[i].next;
}
}
for(int i=0;i<t;i++){
if(b[i].data>k){
v[j].adress=b[i].adress;
v[j].data=b[i].data;
v[j++].next=b[i].next;
}
}
for(int i=0;i<t;i++){
if(i<t-1)
printf("%05d %d %05d\n",v[i].adress,v[i].data,v[i+1].adress);
else
printf("%05d %d -1\n",v[i].adress,v[i].data);
}
return 0;
}