1133 Splitting A Linked List (25分)——C语言实现

1133 Splitting A Linked List (25分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤10^​3). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10^​5 ,10^5], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

题目大意及思路:

第一个为自己的地址adress,中间为数据data,最后为下一个结点的地址next。先把数据全部存储到a数组,然后按得链表顺序存储到b数组,最后先循环一遍b数组找到小于零的数放进v[ ],在循环第二遍找到大于零的数小于k的数放进v[ ],最后再循环一遍找到大于k的数放进v[ ]。

代码:

#include<stdio.h>
typedef struct Node{
	int adress;
	int data;
	int next;
}node;
node a[100010],b[100010],v[100010];

int main(){
	int n,start,k,j=0;
	scanf("%d%d%d",&start,&n,&k);
	for(int i=0;i<n;i++){
		int ads,data,next;
		scanf("%d%d%d",&ads,&data,&next);
		a[ads].adress=ads;
		a[ads].data=data;
		a[ads].next=next;
	}
	while(start!=-1){
		b[j].adress=a[start].adress;
		b[j].data=a[start].data;
		b[j].next=a[start].next;
		start=a[start].next;
		j++;
	}
	int t=j;
	j=0;
	for(int i=0;i<t;i++){
		if(b[i].data<0){
			v[j].adress=b[i].adress;
			v[j].data=b[i].data;
			v[j++].next=b[i].next;
		}
	}
	for(int i=0;i<t;i++){
		if(b[i].data>=0 && b[i].data<=k){
			v[j].adress=b[i].adress;
			v[j].data=b[i].data;
			v[j++].next=b[i].next;
		}
	}
	for(int i=0;i<t;i++){
		if(b[i].data>k){
			v[j].adress=b[i].adress;
			v[j].data=b[i].data;
			v[j++].next=b[i].next;
		}
	}
	for(int i=0;i<t;i++){
		if(i<t-1)
		    printf("%05d %d %05d\n",v[i].adress,v[i].data,v[i+1].adress);
		else
	        printf("%05d %d -1\n",v[i].adress,v[i].data);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值