【PAT】1133.Splitting A Linked List (25)【链表】

题目描述

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

翻译:给定一个单链表,你需要对它的元素重新进行排序来使所有的负数节点出现在非负数节点的前面,所有值为[0,K]的值出现在大于K的值的前面。每个层的元素内部顺序不能颠倒。例如,给定的链表为 18→7→-4→0→5→-6→10→11→-2 ,K为10,你需要输出-4→-6→-2→7→0→5→10→18→11。

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer in [−10​5​​ ,10​5], and Next is the position of the next node. It is guaranteed that the list is not empty.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行包括第一个节点的地址,一个正整数N (≤10​5​​),代表节点的总个数,和一个正整数K (≤10​3)。一个节点的地址是一个5位非负整数,NULL用-1表示。
接下来N行,每行按照以下格式描述一个节点:

Address Data Next
Address表示节点的位置,Data表示一个在 [−10​5​​ ,10​5]之间的整数,Next表示下一个节点的位置。数据保证链表非空。

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.


Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218


Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1


解题思路

从表头开始搜索,用三个vector来保存小于0的,大于等于0小于等于K的和大于K的链表,最后按照顺序输出结果即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<vector>
#define INF 99999999
using namespace std;
struct Node{
	int data;
	int next;
}node[100000];

int first,a,N,K;
vector<int> v[3];
int main(){
	scanf("%d%d%d",&first,&N,&K);
	for(int i=0;i<N;i++){
		scanf("%d",&a);
		scanf("%d%d",&node[a].data,&node[a].next);
	}
	while(first!=-1){
		if(node[first].data<0) v[0].push_back(first);
		else if(node[first].data<=K) v[1].push_back(first);
		else v[2].push_back(first);
		first=node[first].next;
	}
	int flag=0;
	for(int i=0;i<3;i++)
		for(int j=0;j<v[i].size();j++)
		if(!flag)
		printf("%05d %d",v[i][j],node[v[i][j]].data),flag=1;
		else
		printf(" %05d\n%05d %d",v[i][j],v[i][j],node[v[i][j]].data),flag=1;
		printf(" -1\n");
	exit(0);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值