【PAT刷题甲级】1057.Stack

1057 Stack (30 分)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10 ^5). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10 ^5 .

Output Specification

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题意

模拟元素进栈出栈过程,主要考察寻找第k小元素,不可直接用sort,会超时。应该使用分块思想(参照晴神宝典)

代码

#include <iostream>
#include <stack>
using namespace std;
int table[100010];				//table[x]表示整数x当前存在的个数
int block[317];					//block[i]表示第i块存在的元素个数
void PeekMedian(int k) {		//寻找第k小的数
	int sum=0;					//sum存放当前累计存在的数的个数
	int idx=0;	                //块号
	while(sum+block[idx]<k) {
		sum+=block[idx++];
	}
	int num=idx*316;	        //idx号块的第一个数
	while(sum+table[num]<k) {
		sum += table[num++];	//累加块内元素个数,直至sum达到k
	}
	printf("%d\n",num);
}
int main() {
	int n,t;
	scanf("%d",&n);
	string s;
	stack<int> st;
	for(int i=0; i<n; i++) {
		cin >> s;
		if(s=="Push") {
			scanf("%d",&t);
			block[t/316]++;
			table[t]++;
			st.push(t);
		} else if(s=="Pop") {
			if(!st.empty()) {
				int top=st.top();
				st.pop();
				block[top/316]--;
				table[top]--;
				printf("%d\n",top);
			} else {
				printf("Invalid\n");
			}
		} else if(s=="PeekMedian") {
			if(!st.empty()) {
				int k,size=st.size();
				if(size%2==0)	k=size/2;
				else	k=(size+1)/2;
				PeekMedian(k);
			} else {
				printf("Invalid\n");
			}
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值