hdoj-【2669 Romantic】

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5234    Accepted Submission(s): 2202


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
  
  
77 51 10 44 34 79
 

Sample Output
  
  
2 -3 sorry

7 -3

<span style="font-size:18px;">#include<cstdio>
#define LL __int64
void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
	if(b==0)
	{
		y=0;
		d=a;
		x=1;
	}
	else
	{
		exgcd(b,a%b,d,y,x);
		y-=x*(a/b); 
	} 
} 
int main()
{
	LL a,b;
	while(scanf("%I64d%I64d",&a,&b)!=EOF)
	{
		LL x,y,d;
		exgcd(a,b,d,x,y);//d是a,b的最大公约的倍数 
		if(d!=1)
		{
			printf("sorry\n"); 
		} 
		else
		{
			x=x%b;
			LL ans=(x+b)%b;
			y=(1-ans*a)/b;
			printf("%I64d %I64d\n",ans,y);
		} 
	} 
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值