hdoj-【1253 胜利大逃亡】

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35520    Accepted Submission(s): 12591


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output

11

简单,只不过是3维的和二维的没有什么区别

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int map[60][60][60],vis[60][60][60];
int a,b,c,t;
int dx[6]={0,0,-1,1,0,0};
int dy[6]={0,0,0,0,1,-1};
int dz[6]={1,-1,0,0,0,0}; 
struct node
{
	int x,y,z;
	int temp;
}; 
bool bfs()
{
	queue<node>que;
	vis[0][0][0]=1;
	node s;
	s.x=0;s.y=0;s.z=0;
	s.temp=0;
	que.push(s);
	while(!que.empty()) 
	{
		node now;
		now=que.front();
		que.pop();
		if(now.x==a-1&&now.y==b-1&&now.z==c-1&&now.temp<=t)
		{
			t=now.temp;
			return true;
		} 
		if(now.temp+a-1-now.x+b-1-now.y+c-1-now.z>t)
			continue;
		int i;
		node end;
		for(i=0;i<6;++i)
		{
			end.x=now.x+dx[i];
			end.y=now.y+dy[i];
			end.z=now.z+dz[i]; 
			if(vis[end.x][end.y][end.z])
				continue;
			if(end.x<0||end.x>=a||end.y<0||end.y>=b||end.z<0||end.z>=c)
				continue;
			if(map[end.x][end.y][end.z])
				continue; 
			end.temp=now.temp+1;
			vis[end.x][end.y][end.z]=1; 
			que.push(end); 
		} 	 
	}
	return false; 
} 
int main()
{
	int m;
	scanf("%d",&m);
	while(m--)
	{
		memset(vis,0,sizeof(vis)); 
		int i,j,k;
		scanf("%d%d%d%d",&a,&b,&c,&t);
		for(i=0;i<a;++i)
			for(j=0;j<b;++j)
				for(k=0;k<c;++k)
					scanf("%d",&map[i][j][k]);
		if(bfs())
			printf("%d\n",t);
		else
			printf("-1\n");  
	} 
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值