中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。
输入格式:
输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。
输出格式:
按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。
输入样例:
4
This is a test case
输出样例:
asa T
st ih
e tsi
ce s
#include <stdio.h>
#include <string.h>
int main()
{
int n;
scanf("%d", &n);
getchar();
char list[1001] = { 0 };
gets(list);
//char list[1001] = "my friends is tom";//19
int key = 0;
if (strlen(list) % n == 0) {
key = strlen(list);
}
else {
key = strlen(list);
while (1) {
key++;
if (key % n == 0)break;
}
}
for (int i = key - n; i < key; i++) {
int j = i;
for (int r = 0; r < key / n; r++) {
if (j >= strlen(list)) {//当j超出数组范围时,则输出空格补位
printf(" ");
}
else {
printf("%c", list[j]);
}
j -= n;
}
printf("\n");
}
return 0;
}