Minimum Transport Cost

                                            Minimum Transport Cost

原题链接 http://acm.hdu.edu.cn/showproblem.php?pid=1385

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

输入一个n,表示从1到n共n个点,输入n=0时结束程序,并给出n*n的邻接矩阵,d[i][j]=-1表示i->j没有通路,使用Floy算法求解

有多组查询数据,输入u,v两点,输出u->v的最短路并打印字典序最小的路径,以u,v为-1 -1结束。

#include<stdio.h>
#include<string.h>
#define MAXN 110
#define INF 0x3f3f3f3f

int n,cost,s,t;
int c[MAXN],d[MAXN][MAXN],path[MAXN][MAXN];


void Floy()//使用Floy算法
{
    for(int k=1; k<=n; k++)  //中转站k;
    {
        for(int i=1; i<=n; i++) //起点和终点为i,j;
        {
            for(int j=1; j<=n; j++)
            {
                if(d[i][j]>d[i][k]+d[k][j]+c[k])
                {
                    d[i][j]=d[i][k]+d[k][j]+c[k];
                    path[i][j]=path[i][k];//记录路径
                }
                else if(d[i][j]==d[i][k]+d[k][j]+c[k])
                {
                    if(path[i][j]>path[i][k])//按字典序
                    {
                        d[i][j]=d[i][k]+d[k][j]+c[k];
                        path[i][j]=path[i][k];
                    }
                }
            }
        }
    }
    return ;
}

void print_path(int u, int v)//u是起点v是终点
{
    if(u==v)
    {
        printf("%d",v);
        return ;
    }
    int k=path[u][v];
    printf("%d-->",u);
    print_path(k,v);
}

int main()
{
    while(scanf("%d",&n),n)
    {
        for(int i=1; i<=n; i++)//输入,并进行初始化
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&d[i][j]);
                if(d[i][j]==-1)
                {
                    d[i][j]=INF;
                }
                path[i][j]=j;
            }
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&c[i]);
        }
        Floy();
        while(scanf("%d%d",&s,&t))
        {
            if(s==-1&&t==-1)
            {
                break;
            }
            cost=d[s][t];
            if(s==t)  //判断起点和终点是否相同
            {
                printf("From %d to %d :\n",s,t);
                printf("Path: %d\n",s);
                printf("Total cost : %d\n\n",cost);
                continue;
            }
            printf("From %d to %d :\n",s,t);
            printf("Path: ");
            print_path(s,t);
            printf("\n");
            printf("Total cost : %d\n\n",cost);
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值