Drainage Ditches

                                                                                    Drainage Ditches  

原题链接 http://acm.hdu.edu.cn/showproblem.php?pid=1532

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch. 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

m个池塘,1为源点,m为汇点,,n条有向水渠,给出这n条水渠所连接的点和所能流过的最大流量,求出从起点到终点所能流过的最大流量。使用网络流的最大流模板套题即可。

#include<cstdio>
#include<cstring>
#define MAXN 210

struct Matrix
{
    int c,f;
};

Matrix edge[MAXN][MAXN];
int n,m;//流及容量(邻接矩阵)
int s,t;//读入排水沟(即弧)数目,和汇合结点(即顶点)数目
int residual[MAXN][MAXN];//残留网络
int qu[MAXN*MAXN],qe,qs;//队列,队列头,队列尾。
int pre[MAXN];//pre[i]为增广路上顶点i前面的顶点序号
int vis[MAXN];//BFS算法中各顶点的访问标志
int maxflow,min_augment;//最大流流量,每次增广时的可改进量

void find_augment_path()//BFS求增广路
{
    int i,cu;//cu为队列头顶点
    memset(vis,0,sizeof(vis));
    memset(residual,0,sizeof(residual));
    memset(pre,0,sizeof(pre));
    qs=0,qe=1,qu[qs]=s,vis[s]=1;//s入队列
    while(qs<qe&&pre[t]==0)
    {
        cu=qu[qs];
        for(i=1; i<=n; i++)
        {
            if(!vis[i])
            {
                if(edge[cu][i].c-edge[cu][i].f>0)
                {
                    residual[cu][i]=edge[cu][i].c-edge[cu][i].f;
                    pre[i]=cu;
                    qu[qe++]=i;
                    vis[i]=1;
                }
                else if(edge[i][cu].f>0)
                {
                    residual[cu][i]=edge[i][cu].f;
                    pre[i]=cu;
                    qu[qe++]=i;
                    vis[i]=1;
                }
            }
        }
        qs++;
    }
}

void augment_flow()//计算可改进流量
{
    int i=t,j;//t为汇点
    if(!pre[i])
    {
        min_augment=0;
        return;
    }
    j=0x3f3f3f3f;
    while(i!=s)//计算增广路上可改进量的最小值
    {
        if(residual[pre[i]][i]<j)
            j=residual[pre[i]][i];
        i=pre[i];
    }
    min_augment=j;
}

void update_flow()//调整流量
{
    int i=t;//t为汇点
    if(!pre[i])
        return;
    while(i!=s)
    {
        if(edge[pre[i]][i].c-edge[pre[i]][i].f>0)
            edge[pre[i]][i].f+= min_augment;
        else if(edge[i][pre[i]].f>0)
            edge[pre[i]][i].f+= min_augment;
        i=pre[i];
    }
}

void solve()
{
    s=1,t=n;
    maxflow=0;
    while(1)
    {
        find_augment_path();//BFS寻找增广路
        augment_flow();//计算可改进量
        maxflow+=min_augment;
        if(min_augment>0)
            update_flow();//更新流
        else
            return;
    }
}

int main()
{
    int u,v,c;
    while(~scanf("%d%d",&m,&n))
    {
        memset(edge,0,sizeof(edge));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&u,&v,&c);
            edge[u][v].c+=c;
        }
        solve();
        printf("%d\n",maxflow);
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值