Slim Span

                                                        Slim Span

原题链接 http://poj.org/problem?id=3522

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.

 
Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

 
Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
  
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

题意:求出所给图中最小生成树的最大边权值和最小边的权值的最小差值。求解:我们枚举每一条边,并将每一条边都假设为最小边的最小生成树,如果存在最小生成树,就更新最大边和最小边的差值,最后返回差值即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int n,m,flag;
int f[10010];

struct node
{
    int x,y,t;
} q[10010];

int cmp(node a,node b)
{
    return a.t<b.t;
}

int getf(int v)
{
    if(f[v]==v)
    {
        return v;
    }
    else
    {
        return f[v]=getf(f[v]);
    }
}

void merge(int a,int b)
{
    int t1=getf(a);
    int t2=getf(b);
    if(t1!=t2)
        f[t2]=t1;
}

int solve(int v)
{
    int num=0,minn=INF,maxx=-1;
    for(int i=0; i<=n; i++)
    {
        f[i]=i;
    }
    for(int i=v; i<m; i++)
    {
        int t1=q[i].x;
        int t2=q[i].y;
        if(getf(t1)!=getf(t2))//构建最小生成树
        {
            minn=min(minn,q[i].t);//更新最大边权值
            maxx=max(maxx,q[i].t);//更新最小边权值
            merge(t1,t2);
            num++;
        }
        if(num==n-1)//判断是否满足最小生成树条件
        {
            flag=1;
            return maxx-minn;//返回差值
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d%d",&n,&m),n||m)
    {
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&q[i].x,&q[i].y,&q[i].t);
        }
        sort(q,q+m,cmp);
        int minn=-1;
        for(int i=0; i<m; i++)
        {
            flag=0;
            int s=solve(i);//枚举每一条边
            if(flag)//如果flag不为零,就存在最小生成树
            {
                if(minn==-1)
                {
                    minn=s;
                }
                else
                {
                    minn=min(minn,s);
                }
            }
        }
        printf("%d\n",minn);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值