The order of a Tree

                                                   The order of a Tree

原题链接 http://acm.hdu.edu.cn/showproblem.php?pid=3999

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely: 
1.  insert a key k to a empty tree, then the tree become a tree with 
only one node; 
2.  insert a key k to a nonempty tree, if k is less than the root ,insert 
it to the left sub-tree;else insert k to the right sub-tree. 
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape. 

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n. 

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic. 

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

给出一个序列,用它来构造一棵二叉搜索树,并找出一个序列使它满足用它所构成的二叉搜索树与给出的序列所构建的二叉搜索树相同,并保证其字典序为最小。构建二叉树后,我们只需要进行先序遍历便可以得到所求序列。

#include<stdio.h>
#include<string.h>
#define N 100010

int flag,m;//flag用于标记处理后的数据
int l[N],r[N],t[N],a[N];

void init()//数组初始化
{
    memset(l,0,sizeof l);
    memset(r,0,sizeof r);
}

void insert(int a,int b)
{
    if(b<=t[a])//判断是否可以放在左子树上
    {
        if(l[a]) insert(l[a],b);
        else l[a]=flag;//标记处理后的数
    }
    else//判断是否可以放在右子树上
    {
        if(r[a]) insert(r[a],b);
        else r[a]=flag;//标记处理后的数
    }
}

void ac(int n)
{
    a[m++]=t[n];//存储数的顺序
    //左右检查树的构建是否完成
    if(l[n]) ac(l[n]);
    if(r[n]) ac(r[n]);
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        flag=0;
        int x,point=-1;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            if(point==-1)
            {
                t[++point]=x;
            }
            else
            {
                t[++flag]=x;
                insert(point,x);//开始判断
            }
        }
        m=0;
        ac(point);//存储,检测
        printf("%d",a[0]);//输出
        for(int i=1; i<m; i++)
        {
            printf(" %d",a[i]);
        }
        printf("\n");
    }
    return 0;
}

 

内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值