The order of a Tree
原题链接 http://acm.hdu.edu.cn/showproblem.php?pid=3999
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1. insert a key k to a empty tree, then the tree become a tree with
only one node;
2. insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
Sample Input
4
1 3 4 2
Sample Output
1 3 2 4
给出一个序列,用它来构造一棵二叉搜索树,并找出一个序列使它满足用它所构成的二叉搜索树与给出的序列所构建的二叉搜索树相同,并保证其字典序为最小。构建二叉树后,我们只需要进行先序遍历便可以得到所求序列。
#include<stdio.h>
#include<string.h>
#define N 100010
int flag,m;//flag用于标记处理后的数据
int l[N],r[N],t[N],a[N];
void init()//数组初始化
{
memset(l,0,sizeof l);
memset(r,0,sizeof r);
}
void insert(int a,int b)
{
if(b<=t[a])//判断是否可以放在左子树上
{
if(l[a]) insert(l[a],b);
else l[a]=flag;//标记处理后的数
}
else//判断是否可以放在右子树上
{
if(r[a]) insert(r[a],b);
else r[a]=flag;//标记处理后的数
}
}
void ac(int n)
{
a[m++]=t[n];//存储数的顺序
//左右检查树的构建是否完成
if(l[n]) ac(l[n]);
if(r[n]) ac(r[n]);
}
int main()
{
int n;
while(~scanf("%d",&n))
{
flag=0;
int x,point=-1;
for(int i=0; i<n; i++)
{
scanf("%d",&x);
if(point==-1)
{
t[++point]=x;
}
else
{
t[++flag]=x;
insert(point,x);//开始判断
}
}
m=0;
ac(point);//存储,检测
printf("%d",a[0]);//输出
for(int i=1; i<m; i++)
{
printf(" %d",a[i]);
}
printf("\n");
}
return 0;
}