HDU 3999 The order of a Tree (二叉搜索树+先序遍历)

The order of a Tree


Problem Description
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
 

Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
 

Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
 

Sample Input
  
  
4 1 3 4 2
 

Sample Output
  
  
1 3 2 4

题意:题意给出一个序列,构造一棵二叉搜索树,让你找一个序列,满足:能构成与给出的序列相同的二叉搜索树,同时,字典序最小。

分析:首先构造二叉搜索树,然后先序遍历输出即可。

AC代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
typedef struct node{
	int data;
	node *lchild,*rchild; 
}*Tree,tree;
Tree root;
int n;
	
void insert(Tree& root,int t){
	if(root==NULL){
		root=(Tree)malloc(sizeof(tree));
		root->data=t;
		root->lchild=NULL;
		root->rchild=NULL;
	}
	else if(t<root->data){
		insert(root->lchild,t);
	}
	else insert(root->rchild,t);
}

void preOder(Tree root,int& cnt){
  	if(root==NULL)return ; 
	cnt++;   //用于控制输出格式 
  	if(cnt!=n)
  	printf("%d ",root->data);
  	else printf("%d\n",root->data);
  	preOder(root->lchild,cnt);
  	preOder(root->rchild,cnt);
}

int main(){
	
	while(scanf("%d",&n)==1){
		int t;
		for(int i=0;i<n;i++)
        {
        scanf("%d",&t);
		insert(root,t);
		}
		
		int cnt=0;
		preOder(root,cnt);
	}
	return 0;
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值