HDU 1005 Number Sequence【序列号】

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 169920 Accepted Submission(s): 41910
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

Author
CHEN, Shunbao

Source
ZJCPC2004*

意思就是有个公式,f(1)=1 , f(2)=1 , f(n)=(A x f(n-1)+B x f(n-2)) mod 7。A,B将会在每个测试数据中输入。

跟斐波那契数列一个思路,就是慢慢往上推嘛。
于是我就用递归法写了一个。


int f(int n){
    if(n==1||n==2)
        return 1;
    return (A*f(n-1)+B*f(n-2))%7;
}

于是,Memory Limit Exceeded。
嗯,那我用迭代(循环)。

 int a,b,c;
        a=1;b=1;
        if(n==1||n==2)
            printf("1\n");
        else{
            for(int i=2;i<n;++i){
                c=(A*b+B*a)%7;
                a=b;
                b=c;
            }

嗯,Time Limit Exceeded。

好吧,我还是too young。我上网搜了一下题解,他们是这么说的:

1.n的数值很大,这类数值很大的问题一般都有规律,找出循环节(周期)是关键;
2.找规律,这道题是从 f(1) = 1 和 f(2) = 1 开始,然后依次模7,可知 f(n) 只有7种情况,所以两数相邻只有7*7=49种;
3.所以从 f(1) 到 f(49) 必会出现相邻两个 f(m-1) = 1 , f(m) = 1,所以 f(n) 为周期函数,49为其一个周期
需要注意的地方:
做题的时候不要盲目的上手去做,先要仔细分析题目,先动脑再动手

先动脑在动手这句话说对了,,,,我不该那么傻的。
不过我也不知道为啥49个一个周期,呜呜。不过代码经过修改反正是过去了。

AC 代码:

#include<cstdio>
int A,B;
int main(){
    int n;
    while(~scanf("%d %d %d",&A,&B,&n)&&A&&B&&n){
        int a,b,c;
        a=1;b=1;
        n%=49;
        if(n==1||n==2)
            printf("1\n");
        else{
            for(int i=2;i<n;++i){
                c=(A*b+B*a)%7;
                a=b;
                b=c;
            }
            printf("%d\n",c);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值