hdu1005Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 108178    Accepted Submission(s): 26289


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
#include<stdio.h>
#include<math.h>
int fun(int a,int b,int n)
{
	if(n==1)
	return 1;
	else if(n==2)
	return 1;
	else return (a*fun(a,b,n-1)+b*fun(a,b,n-2))%7;
}
int main()
{
	int A,B,N;
	while(scanf("%d%d%d",&A,&B,&N)!=EOF)
	{
		if(A==0&&B==0&&N==0)
		break;
		else printf("%d\n",fun(A,B,N%49));
	}
	return 0;
}

/*1、根据周期,可以快速获得结果,且周期必定小于49.
   周期的原因:如果<f(x),f(x+1)>的值与<f(x+T),f(x+1+T)>一致,那么以后的序列就完全一致了。
   周期小于49的原因: 由于mod 7,所以<f(x),f(x+1)>的可能为49个,那么50个这样的<f(x),f(x+1)>必定有两个相同(鸽笼原理),所以最终可以确定周期小于49.
2、需要注意的是:并不是整个序列是有周期的,而是其中去掉头部一部分以后是有周期的!!!举个特殊的例子A=7,B=7,那么{f(x)}为{1,1,0,0,0,0,...},其在去掉头部的两个1后是有周期的,所以应该求出这个头部。类似的例子还有{A=2,B=7},{A=3,B=7}...
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值