1059. C语言竞赛

C语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

0. 冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
1. 排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
2. 其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的ID,你要给出这些参赛者应该获得的奖品。

输入格式:

输入第一行给出一个正整数N(<=10000),是参赛者人数。随后N行给出最终排名,每行按排名顺序给出一位参赛者的ID(4位数字组成)。接下来给出一个正整数K以及K个需要查询的ID。

输出格式:

对每个要查询的ID,在一行中输出“ID: 奖品”,其中奖品或者是“Mystery Award”(神秘大奖)、或者是“Minion”(小黄人)、或者是“Chocolate”(巧克力)。如果所查ID根本不在排名里,打印“Are you kidding?”(耍我呢?)。如果该ID已经查过了(即奖品已经领过了),打印“ID: Checked”(不能多吃多占)。

输入样例:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
输出样例:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

===========================================================================

水题。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <iomanip>
#include <cctype>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
using namespace std;

bool prime(int x);

struct attender
{
    int rank;
    int num;
    bool flag;
};

int main()
{
    int i,n;
    attender arr[10005];
    cin>>n;
    for(i=0;i<n;i++)
    {
        arr[i].rank = i+1;
        cin>>arr[i].num;
        arr[i].flag = false;
    }
    int temp,m;
    bool f;
    cin>>m;
    while(m--)
    {
        cin>>temp;
        f = false;
        for(i=0;i<n;i++)
        {
            if(arr[i].num == temp)
            {
                f = true;
                cout<<setw(4)<<setfill('0')<<arr[i].num<<": ";
                if(arr[i].flag == false)
                {
                    arr[i].flag = true;
                    if(arr[i].rank == 1)
                        cout<<"Mystery Award"<<endl;
                    else if(prime(arr[i].rank) == true)
                        cout<<"Minion"<<endl;
                    else
                        cout<<"Chocolate"<<endl;
                }
                else
                    cout<<"Checked"<<endl;
                break;
            }
        }
        if(f == false)
            cout<<temp<<": Are you kidding?"<<endl;
    }
	return 0;
}

bool prime(int x)
{
    int i;
	if(x <= 1)
		return false;
	if(x == 2)
		return true;
	else
	{
		for(i=2;i<=sqrt((double)x)+1;i++)
		{
			if(x%i == 0)
				return false;
		}
		return true;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值