题目1096:日期差值 Java/C++

题目描述:

有两个日期,求两个日期之间的天数,如果两个日期是连续的我们规定他们之间的天数为两天

输入:

有多组数据,每组数据有两行,分别表示两个日期,形式为YYYYMMDD

输出:

每组数据输出一行,即日期差值

样例输入:
20110412
20110422
样例输出:
11


Java AC 代码:

import java.util.Scanner;
 
public class Main {
 
        /**
         * @param args
         */
        public static void main(String[] args) {
                // TODO Auto-generated method stub
                int date1, date2;
                Scanner inScanner = new Scanner(System.in);
                while (inScanner.hasNext()) {
                        date1 = inScanner.nextInt();
                        date2 = inScanner.nextInt();
                        int temp;
                        if (date1 > date2) {
                                temp = date1;
                                date1 = date2;
                                date2 = temp;
                        }
 
                        int year1, month1, day1, year2, month2, day2;
                        year1 = date1 / 10000;
                        month1 = (date1 / 100) % 100;
                        day1 = date1 % 100;
                        year2 = date2 / 10000;
                        month2 = (date2 / 100) % 100;
                        day2 = date2 % 100;
 
                        System.out.println(diff(year1, month1, day1, year2, month2, day2));
                }
        }
 
        public static boolean isLeap(int year) {
               
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值