2019春季PAT考试甲级答案

20190302春季PAT考试甲级答案
7-1 Sexy Primes (20 分)
Sexy primes are pairs of primes of the form (p, p+6), so-named since “sex” is the Latin word for “six”. (Quoted from http://mathworld.wolfram.com/SexyPrimes.html)

Now given an integer, you are supposed to tell if it is a sexy prime.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤108​​ ).

Output Specification:
For each case, print in a line Yes if N is a sexy prime, then print in the next line the other sexy prime paired with N (if the answer is not unique, output the smaller number). Or if N is not a sexy prime, print No instead, then print in the next line the smallest sexy prime which is larger than N.

Sample Input 1:
47
Sample Output 1:
Yes
41

Sample Input 2:
21
Sample Output 2:
No
23
分析:此题难度不大,考察点是利用循环进行素数的判断。
首先明白Sexy primes的定义,如果N为素数,且N+6或者N-6也为素数,则N为Sexy prime。
输出要求:
1.如果N是素数,且N+6也为素数,则N为Sexy prime,输出Yes(换行)输出N。
2.或者N是素数,且N-6也为素数,则N为Sexy prime,输出No(换行)输出N-6。
3.如果N不是Sexy prime,则输出比N大的Sexy prime里面最小的那个数字。

#include <stdio.h>
int IsPrime(int N)
{
	int i,flag=1;
	for(i=2;i<N;i++)
	{
		if(N%i==0)
		{
			flag=0;
			break;
		}
	}
	return flag;
}
int main()
{
	int N,x;
	scanf("%d",&N);
	if(IsPrime(N)&&IsPrime(N+6))
	{
		printf("Yes\n%d",N);
	}
	else if(IsPrime(N)&&IsPrime(N-6))
	{
		printf("Yes\n%d",N-6);
	}
	else 
	{
		printf("No\n");
		for(x=N;IsPrime(x)==0;x++)
		{}
		printf("%d",x); 
	}
	return 0;
}

7-2 Anniversary (25 分)
Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID’s of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:
Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤10​5 ). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID’s are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤10​5​​ ). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID’s are distinct.

Output Specification:
First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus – notice that the 7th - 14th digits of the ID gives one’s birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:
5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042
Sample Output:
3
分析:浙江大学校庆,统计了校友会的N位贵宾,还有所有实际到场的M位来宾,每位宾客均有自己的18位ID号。输入
输入要求:
1.输入N。
2.输入每位贵宾的ID。
3.输入M.。
4.输入每位来宾的ID。
输出要求:
1.输出在所有来宾中的贵宾总数。
2.输出到场的贵宾中最年长的那位的ID,如果没有贵宾到场,则输出所有来宾中最年长的那位的ID。

#include<stdio.h>
//构造结构体 
struct Per
{
	char ID[19];	
 } ;
 struct Per al[100000],gu[100000];//al代表alumni,gu代表gust 
 int main ()
 {
 	
 	int N,M,i,j,s,sum=0,flag;
 	int old[100000];
 	scanf("%d",&N);
 	//根据输入的N的个数来确定输入的al的ID 
 	for(i=0;i<N;i++)
 	{
 		for(j=0;j<19;j++)
 		scanf("%c",&al[i].ID[j]);
	}
	//根据输入的M的个数来确定输入的gu的ID 
	scanf("%d",&M);
 	for(i=0;i<M;i++)
 	{
 		for(j=0;j<19;j++)
 		scanf("%c",&gu[i].ID[j]);
	}
	//将al与gu逐项对比,来确认实际到场的al的总数sum 
	for(i=0;i<N;i++)
	{
		for(j=0;j<M;j++)
		{
			for(s=0;s<19;s++)
			{
				if(al[i].ID[s]!=gu[j].ID[s])
				break;
				else if(s==18)
				{
					old[sum]=i;
					sum++;
				}	
			}
		}
	}
	printf("%d",sum);
	//如果有实际到场的al,则确定这些到场的al中最老的那一位 
	if(sum!=0)
	{
		flag=old[0];
		for(i=1;i<sum;i++)
		{
			j=old[i];
			for(s=6;s<14;s++)
			{
				if(al[flag].ID[s]>al[j].ID[s])
				{
					flag=j;
					break;
				}
			}
		}
		for(j=0;j<19;j++)
 		printf("%c",al[flag].ID[j]);
	}
	//如果没有实际到场的al,则确定这些到场的gu中最老的那一位 
	else if(sum==0)
	{
		flag=0;
		for(i=1;i<M;i++)
		{
			for(s=6;s<14;s++)
			{
				if(gu[flag].ID[s]>gu[i].ID[s])
				{
					flag=i;
					break;
				}
					
			}
			
		}
		for(j=0;j<19;j++)
 		printf("%c",gu[flag].ID[j]);
	}
	
 	return 0;
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值