HDU 5726 GCD(RMQ+二分)(线段树也可)

Problem Description

Give you a sequence of N(N≤100,000) integers : a1,...,an(0<ai≤1000,000,000). There are Q(Q≤100,000) queries. For each query l,r you have to calculate gcd(al,,al+1,...,ar) and count the number of pairs(l′,r′)(1≤l<r≤N)such that gcd(al′,al′+1,...,ar′) equal gcd(al,al+1,...,ar).

Input

The first line of input contains a number T, which stands for the number of test cases you need to solve.

The first line of each case contains a number N, denoting the number of integers.

The second line contains N integers, a1,...,an(0<ai≤1000,000,000).

The third line contains a number Q, denoting the number of queries.

For the next Q lines, i-th line contains two number , stand for the li,ri, stand for the i-th queries.

Output

For each case, you need to output “Case #:t” at the beginning.(with quotes, t means the number of the test case, begin from 1).

For each query, you need to output the two numbers in a line. The first number stands for gcd(al,al+1,...,ar) and the second number stands for the number of pairs(l′,r′) such that gcd(al′,al′+1,...,ar′) equal gcd(al,al+1,...,ar).

Sample Input

1
5
1 2 4 6 7
4
1 5
2 4
3 4
4 4

Sample Output

Case #1:
1 8
2 4
2 4
6 1

可蛋疼的一个题,一开始想用线段树来搞,但是第二部分的查询没想出来,发现网上大神们多用RMQ解决,学习一番后总结如下:

这题能用rmq是因为满足rmq那个转移方程(还是线段树更全能啊。。。);

区间增长后gcd快速减小至1也是降低时间复杂度的重要依据;

第二部分直接对每个L,进行对R的二分,用map统计得出结果;

代码如下:

#include <bits/stdc++.h>
#define rep(i,j,k) for(int i = j; i <= k; i++)
#define LL long long
using namespace std;
int n, m;
int f[100010][18];
int a[100010];
map<int, LL>mp;
int gcd(int a, int b) {return b?gcd(b,a%b):a;}
void rmq(){
    rep(i,1,n) f[i][0] = a[i];
    rep(j,1,17)
        rep(i,1,n)
            if(i+(1<<j)-1 <= n)
                f[i][j] = gcd(f[i][j-1], f[i+(1<<j-1)][j-1]);
}
int ser(int l, int r){
    int k = (int)log2((double)(r - l + 1));
    return gcd(f[l][k],f[r-(1<<k)+1][k]);
}
void setTable(){
    mp.clear();
    rep(i,1,n){
        int g = f[i][0],j = i;
        while(j <= n){
            int l = j, r = n;
            while(l < r){
                int mid = (l+r+1)>>1;
                if(ser(i, mid) == g) l = mid;
                else r = mid - 1;
            }
            mp[g] += l-j+1;
            j = l + 1;
            g = ser(i,j);
        }
    }
}
int main(){
    int t, l, r;
    int cas = 1;
    cin >> t;
    while(t--){
        cin >> n;
        rep(i,1,n) scanf("%d", a+i);
        rmq();
        setTable();
        cin >> m;
        printf("Case #%d:\n", cas++);
        rep(i,0,(m-1)){
            scanf("%d%d", &l, &r);
            int tmp = ser(l, r);
            printf("%d %I64d\n", tmp, mp[tmp]);
        }
    }
    return 0;
}

学习到新东西了…

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值