HDU 5775 Bubble Sort(逆序对)

Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

求出逆序对算一算最大能达到的左右距离之差就好了,写法不一,这里用线段树求逆序对。

最右位置:每个值右边有多少个比其小的值,加上原位置得到;
最左位置:初始位置和最终位置较小的那个。

ac代码:

#include <bits/stdc++.h>

using namespace std;

#define rep(i,a,n) for(int i = (a); i < (n); i++)
#define per(i,a,n) for(int i = (n)-1; i >= a; i--)
#define clr(arr,val) memset(arr,val,sizeof(arr))
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define pi acos(-1)
typedef long long LL;
typedef pair<int, int> pii;
const double eps = 1e-8;
const int maxn = 100005;
int segtree[maxn<<2];
int a[maxn<<1], b[maxn<<1];
void pushup(int n){
    segtree[n] = segtree[n<<1] + segtree[n<<1|1];
}
void update(int v, int l, int r, int num){
    if(l == r && l == num){
        segtree[v] = 1;
        return;
    }
    int mid = (l+r)>>1;
    if(num > mid) update(v<<1|1, mid+1, r, num);
    else update(v<<1, l, mid, num);
    pushup(v);
}
int get(int l, int r, int v, int le, int ri)
{
    int res=0;
    if(l >= le && r <= ri)
        return segtree[v];
    int mid = (l+r)>>1;
    if(mid >= le) res += get(l, mid, v<<1, le, ri);
    if(mid < ri) res += get(mid+1, r, v<<1|1, le, ri);
    return res;
}
int main(int argc, char const *argv[]) {
    int t, n;
    cin >> t;
    int cas = 1,tmp;
    while (t--) {
        clr(segtree,0);
        scanf("%d",&n);
        rep(i, 1, n+1) {
            scanf("%d", &tmp);
            a[tmp] = i;
        }
        rep(i, 1, n+1) {
            b[i] = get(1,n,1,a[i],n);
            update(1,1,n,a[i]);
        }
        printf("Case #%d:",cas++);
        rep(i, 1, n+1)
            printf(" %d", abs(min(i, a[i]) - max(i, a[i]+b[i])));
        puts("");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值