POJ 1050 To the Max(DP_最大字段和)

题目链接

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15



        求最大子矩阵和
解题思路:
           a11  a12  a13
        a21  a22  a23
        a31  a32  a33   
        可以先求出a11, a12, a13的最大子段和,然后再求出a11+a21, a12+a22, a13+a23的最大子段和,接着求a11+a21+a31, a12+a22+a32, a13+a23+a33的最大子段和,求完以第一行开头的,再接着求以第二行开头的,以此类推求出所有的最大子段和,求出他们中最大的就是解。

代码如下:

/*
                                    _ooOoo_
                                   o8888888o
                                   88" . "88
                                   (| -_- |)
                                    O\ = /O
                                ____/`---'\____
                              .   ' \\| |// `.
                               / \\||| : |||// \
                             / _||||| -:- |||||- \
                               | | \\\ - /// | |
                             | \_| ''\---/'' | |
                              \ .-\__ `-` ___/-. /
                           ___`. .' /--.--\ `. . __
                        ."" '< `.___\_<|>_/___.' >'"".
                       | | : `- \`.;`\ _ /`;.`/ - ` : | |
                         \ \ `-. \_ __\ /__ _/ .-` / /
                 ======`-.____`-.___\_____/___.-`____.-'======
                                    `=---='

                 .............................................
*/
#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define pi 3.1415926
#define INF 123456789
using namespace std;
int main(){
    int n, i, j, a[105][105], b[105], q, t, Max;
    while(~scanf("%d", &n)){
        for(i = 0; i < n; i ++){
            for(j = 0; j < n; j ++)
                scanf("%d", &a[i][j]);
        }
        for(i = 0, Max = -INF; i < n; i ++){
            memset(b, 0, sizeof(b));
            for(j = i; j < n; j ++){
                for(q = 0; q < n; q ++)
                    b[q] += a[j][q];
                for(q = 0, t = 0; q < n; q ++){
                    t += b[q];
                    if(t > Max) Max = t;
                    if(t < 0) t = 0;
                }
            }
        }
        printf("%d\n", Max);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值