POJ 1050 To the Max

To the Max
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 48349
Accepted: 25582

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

Sample Output

15

Source

Greater New York 2001

---------------------------------华丽的分割线-------------------------------


问题描述:
给定一个N阶方阵(正负不定),求其n阶子阵和的最大值(子阵必须是连在一起的)。

解体思路:
DP, 求最大字段和。题目给出是二维的,故降低其维数以一维字段和的方法解决。

Code:
#include<stdio.h>
#include<cstring>
#define MAX 101
int main()
{
    int i,j,k,n,m,ans,max1,sum1,line[MAX][MAX];
    scanf("%d",&n);
    memset(line,0,sizeof(line));
    for(i=1;i<=n;i++)
        for(j=1;j<=n;j++){
            scanf("%d",&m);
            line[i][j]=line[i][j-1]+m;//line[i][j]为第i行前j个元素的和
        }
    max1=0;
    for(i=0;i<=n;i++)
        for(j=i,sum1=0;j<=n;sum1=0,j++)//这里是对列区间[i+1,j]的枚举,故此降低了维数
            for(k=1;k<=n;k++){
                if(sum1<0)sum1=0;
                sum1+=line[k][j]-line[k][i];//以这个差为新的数列(区间内的和),对行数求最大字段和
                if(sum1>max1)max1=sum1;
            }
    printf("%d\n",max1);
    return 0;
}






  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值