ZOJ1562 More Divisors

3 篇文章 0 订阅

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1562

More Divisors


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Everybody knows that we use decimal notation, i.e. the base of our notation is 10. Historians say that it is so because men have ten fingers. Maybe they are right. However, this is often not very convenient, ten has only four divisors -- 1, 2, 5 and 10. Thus, fractions like 1/3, 1/4 or 1/6 have inconvenient decimal representation. In this sense the notation with base 12, 24, or even 60 would be much more convenient.

The main reason for it is that the number of divisors of these numbers is much greater -- 6, 8 and 12 respectively. A good quiestion is: what is the number not exceeding n that has the greatest possible number of divisors? This is the question you have to answer.

Input:

The input consists of several test cases, each test case contains a integer n (1 <= n <= 1016).

Output:

For each test case, output positive integer number that does not exceed n and has the greatest possible number of divisors in a line. If there are several such numbers, output the smallest one.

Sample Input:

10
20
100

Sample Output:

6
12
60

求 n 以内因子数最多的数
#include<iostream>
#include<cstdio>
using namespace std;
#define LL long long
#define INF 0x7fffffffffffffff
LL n, ans, ans_num;
LL p[16]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53};
void dfs(LL dep, LL tmp, LL num, LL up){
	if(tmp>n || dep>=16) return;
	if(num>ans_num){
		ans_num=num;
		ans=tmp;
	}
	if(num==ans_num && tmp<ans) ans=tmp;
	for(int i=1;i<=up;++i){
		if(tmp*p[dep]>n) break;
		dfs(dep+1,tmp=tmp*p[dep],num*(i+1),i);
	}
}
int main()
{
	while(~scanf("%lld",&n)){
		ans=INF, ans_num=0;
		dfs(0,1,1,60);
		printf("%lld\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值