Coin Change

传送门

题目描述

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money. For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent. Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11

26

Sample Output

4

1

题意:有5种硬币,分别是1,5,10,25,50。现有钱由这5种硬币组成,求共有多少种组成方式。

思路:每种硬币可以无限制取,可以看成完全背包模型,所以状态转移方程是dp[j]=dp[j]+dp[j-a[i]]

代码

#include<iostream>
#define ll long long
#include<cstring>
using namespace std;
ll dp[10005];
ll a[6]={0,1,5,10,25,50};
int main()
{
	int n;
	while(cin>>n)
	{
		dp[0]=1;
		for(int i=1;i<=5;i++)
		{
			for(int j=0;j<=n;j++)
			{
				dp[j+a[i]]=dp[j]+dp[j+a[i]];
			}
		}
		cout<<dp[n]<<endl;
		memset(dp,0,sizeof(dp));
	}
	return 0;
}

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值