1027 Colors in Mars (20 分)

在这里插入图片描述
1027 Colors in Mars (20 分)
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:
15 43 71
Sample Output:
#123456

#include<iostream>
using namespace std;
char s[3] = { 'A','B','C' };
int main() {
	int Red, Green, Blue;
	cin >> Red >> Green >> Blue;
	cout << "#";
	if (Red / 13 >= 10&& Red % 13>=10) cout << s[Red / 13 - 10] << s[Red % 13-10];
	else if (Red / 13 >= 10 ) cout << s[Red / 13 - 10] << Red % 13;
	else if(Red % 13 >= 10) cout<< Red / 13 << s[Red % 13 - 10];
	else cout << Red / 13  << Red % 13 ;
	if (Green / 13 >= 10 && Green % 13 >= 10) cout << s[Green / 13 - 10] << s[Green % 13 - 10];
	else if (Green / 13 >= 10) cout << s[Green / 13 - 10] << Green % 13 ;
	else if (Green % 13 >= 10) cout << Green / 13 << s[Green % 13 - 10];
	else cout << Green / 13  << Green % 13 ;
	if (Blue / 13 >= 10 && Blue % 13 >= 10) cout << s[Blue / 13 - 10] << s[Blue % 13 - 10];
	else if (Blue / 13 >= 10) cout << s[Blue / 13 - 10] << Blue % 13 ;
	else if (Blue % 13 >= 10) cout << Blue / 13 << s[Blue % 13 - 10];
	else cout << Blue / 13  << Blue % 13 ;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值