HUST 1010 The Minimum Length

1010 - The Minimum Length

Time Limit: 1s Memory Limit: 128MB

Submissions: 1382 Solved: 519
Description
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A.For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
Input
Multiply Test Cases.For each line there is a string B which contains only lowercase and uppercase charactors.The length of B is no more than 1,000,000.
Output
For each line, output an integer, as described above.
Sample Input
bcabcab
efgabcdefgabcde
Sample Output
3
7


这个题目是给定一个由一段字符串A重复组成的字符串B的一部分,且至少包含一个字符串A,求出那个串A的长度

这个题目再次彰显KMP的强大。。。

因为是至少包含一个完整的A,所以开头第一个字母与后面组成的一个串长为要求的串A的长度的序列一定与A是同构的,那么由KMP算法求得的第m+1位的那个字符的next值与给出的字符串总长的差一定是这个要求的串A的长度。


代码如下:

/*************************************************************************
	> File Name: The_Minimum_Length.cpp
	> Author: Zhanghaoran
	> Mail: chilumanxi@xiyoulinux.org
	> Created Time: Wed 25 Nov 2015 12:17:00 AM CST
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;
int Max = 0;
void preKmp(char x[], int m, int kmp_Next[]){
    int i, j;
    j = -1;
    kmp_Next[0] = -1;
    i = 0;
    while(i < m){
        if(j == -1 || x[i] == x[j]){
            kmp_Next[++i] = ++ j;
        }
        else
            j = kmp_Next[j];
        if(Max < j)
            Max = j;
    }
    kmp_Next[0] = 0;
}
int nexti[1000010];
char a[1000010];
int main(void){
    while(~scanf("%s", a)){
        preKmp(a, strlen(a), nexti);
        cout << strlen(a) - nexti[strlen(a)] << endl;
        Max = 0;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值