DFS——Red and Black

题目

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output
45
59
6
13
与lake counting题结构相似,不过只需从一个地方开始。下面代码可以将输入与找@合并,scanf放在循环里。

#include<stdio.h>
#include<string.h>
int w,h,tx,ty,cnt=1,max=0;		//w为行数,h为列数
char a[27][27],flag[27][27];	//flag记录该位置有没被访问过
int next[4][2]={				//四个方向
 1,0,
 0,1,
-1,0,
 0,-1
};
void dfs(int x,int y){			//递归函数
	for(int v=0;v<4;v++){		//在每个地方都有四个方向可走
		int dx=x+next[v][0];
		int dy=y+next[v][1];
		if(a[dx][dy]=='.'&&dx>0&&dx<=w&&dy>0&&dy<=h&&!flag[dx][dy]){
			flag[dx][dy]=1;
			dfs(dx,dy);
		}
	}
}
int main(){
	scanf("%d %d",&h,&w);
	while(h&&w){			//都不为0
		getchar();
		for(int i=1;i<=w;i++){//输入数据
			for(int j=1;j<=h;j++){
				scanf("%c",&a[i][j]);
			}
			getchar();
		}
		memset(flag,0,sizeof(flag));
		for(int i=1;i<=w;i++){
			for(int j=1;j<=h;j++){
				if(a[i][j]=='@'){	//从@开始
					tx=i;
					ty=j;
				}
			}
		}
		dfs(tx,ty);
		for(int i=1;i<=w;i++){		//数flag表里有几个1
			for(int j=1;j<=h;j++){
				if(flag[i][j]==1){
					cnt++;
				}
			}
		}
/*		for(int i=1;i<=w;i++){		//输出flag表
			for(int j=1;j<=h;j++){
				printf("%2.d",flag[i][j]);
			}
			printf("\n");
		}*/
		printf("%d\n",cnt);
		cnt=1;
		scanf("%d %d",&h,&w);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值