DFS——Red and Black

题目

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output
45
59
6
13
与lake counting题结构相似,不过只需从一个地方开始。下面代码可以将输入与找@合并,scanf放在循环里。

#include<stdio.h>
#include<string.h>
int w,h,tx,ty,cnt=1,max=0;		//w为行数,h为列数
char a[27][27],flag[27][27];	//flag记录该位置有没被访问过
int next[4][2]={				//四个方向
 1,0,
 0,1,
-1,0,
 0,-1
};
void dfs(int x,int y){			//递归函数
	for(int v=0;v<4;v++){		//在每个地方都有四个方向可走
		int dx=x+next[v][0];
		int dy=y+next[v][1];
		if(a[dx][dy]=='.'&&dx>0&&dx<=w&&dy>0&&dy<=h&&!flag[dx][dy]){
			flag[dx][dy]=1;
			dfs(dx,dy);
		}
	}
}
int main(){
	scanf("%d %d",&h,&w);
	while(h&&w){			//都不为0
		getchar();
		for(int i=1;i<=w;i++){//输入数据
			for(int j=1;j<=h;j++){
				scanf("%c",&a[i][j]);
			}
			getchar();
		}
		memset(flag,0,sizeof(flag));
		for(int i=1;i<=w;i++){
			for(int j=1;j<=h;j++){
				if(a[i][j]=='@'){	//从@开始
					tx=i;
					ty=j;
				}
			}
		}
		dfs(tx,ty);
		for(int i=1;i<=w;i++){		//数flag表里有几个1
			for(int j=1;j<=h;j++){
				if(flag[i][j]==1){
					cnt++;
				}
			}
		}
/*		for(int i=1;i<=w;i++){		//输出flag表
			for(int j=1;j<=h;j++){
				printf("%2.d",flag[i][j]);
			}
			printf("\n");
		}*/
		printf("%d\n",cnt);
		cnt=1;
		scanf("%d %d",&h,&w);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
DFS(深度优先搜索)可以用于解决迷宫出口问题。 首先,我们需要将迷宫转化为图,其中每个房间是图中的一个节点,每个房间之间的通道是图中的一条边。我们可以用一个二维数组来表示迷宫,其中0表示墙,1表示通道。 然后,我们可以使用DFS来搜索迷宫。我们从起点开始探索,每次选择一个未被访问的相邻节点进行探索,直到找到出口为止。为了避免陷入死循环,我们需要记录已经访问过的节点。 具体实现可以使用递归或者栈来实现DFS,以下是一个使用递归的示例代码(假设起点为(0,0),出口为(n-1,m-1)): ```python def dfs(x, y, visited, maze): # 判断当前节点是否为出口 if x == len(maze)-1 and y == len(maze[0])-1: return True # 标记当前节点已被访问 visited[x][y] = True # 搜索相邻节点 for dx, dy in [(0,1), (0,-1), (1,0), (-1,0)]: nx, ny = x+dx, y+dy # 判断相邻节点是否合法 if 0 <= nx < len(maze) and 0 <= ny < len(maze[0]) and maze[nx][ny] == 1 and not visited[nx][ny]: # 递归搜索相邻节点 if dfs(nx, ny, visited, maze): return True return False # 测试 maze = [ [1, 0, 1, 1, 1], [1, 0, 1, 0, 1], [1, 0, 1, 0, 1], [1, 1, 1, 0, 1], [0, 0, 0, 0, 1] ] visited = [[False for _ in range(len(maze[0]))] for _ in range(len(maze))] print(dfs(0, 0, visited, maze)) # 输出True,表示存在从起点到出口的路径 ``` 这段代码中,dfs函数的参数分别表示当前搜索的节点坐标、已经访问过的节点、迷宫的二维数组。搜索过程中,我们先判断当前节点是否为出口,如果是,则返回True。然后标记当前节点已被访问,并搜索相邻节点,如果找到了一个相邻节点可以到达出口,则返回True。否则,返回False表示无法到达出口。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值