HDU 1242 Rescue(BFS+优先队列)

2 篇文章 0 订阅
2 篇文章 0 订阅

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26809    Accepted Submission(s): 9496


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 


本题因为打怪需要时间,采用一般的BFS不行,采用DFS又容易会超时,因此采用BFS+优先队列的方式,总是将花费时间少的点放在队列的前面。

下面是AC代码:


#include<iostream>
#include<cstdio>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
const int inf=999999;

int sx,sy,ex,ey;

int n,m,flag;
char map[201][201];
int visited[201][201];
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};

bool legal(int x,int y)
{
    if(map[x][y]=='#'||visited[x][y]||x<1||y<1||x>n||y>m)
        return false;
        return true;
}

struct node
{
    int x,y,t;
};

struct cmp
{
    bool operator()(node a,node b)
    {
        return a.t>b.t;
    }
};
int bfs()
{
    node cur,next;
    cur.x=sx;
    cur.y=sy;
    cur.t=0;
    priority_queue<node,vector<node>,cmp> q;
    q.push(cur);
    while(!q.empty())
    {
        cur=q.top();
        q.pop();
         if(cur.x==ex&&cur.y==ey)
        {
            flag=1;
            return cur.t;
        }
        for(int i=0;i<4;i++)
        {
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            next.t=cur.t+1;
            if(legal(next.x,next.y))
            {
                if(map[next.x][next.y]=='x')
                    next.t++;
                q.push(next);
                visited[next.x][next.y]=1;
            }
        }
    }

}
int main()
{
    while(cin>>n>>m)
    {
        memset(visited,0,sizeof(visited));
        memset(map,'#',sizeof(map));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            cin>>map[i][j];
            if(map[i][j]=='a')
            {
                ex=i;
                ey=j;
            }
            if(map[i][j]=='r')
            {
                sx=i;
                sy=j;
            }
        }
        flag=0;
        int t;
        t=bfs();
        if(flag==1) cout<<t<<endl;
        else cout<< "Poor ANGEL has to stay in the prison all his life."<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值