HDU 1796 How many integers can you find(容斥原理)

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8059    Accepted Submission(s): 2403


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7
 

Author
wangye
 

Source
 

Recommend
wangye
 


题意:给你一个n和一个m个数的集合,求1到n中满足能被集合中一个数整除的数有几个

思路:根据容斥定理,满足条件的数为被集合中一个数整除的数的数量和-能被集合中任意两个数整除的数的数量+三个......

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

int a[20];
int n,m;

void solve()
{
    int res=0;
    for(int i=1;i<(1<<m);i++)
    {
        int num=0;
        for(int j=i;j!=0;j>>=1) num+=j&1;
        int lcm=1;
        for(int j=0;j<m;j++)
        {
            if(i>>j&1)
            {
                lcm=lcm/__gcd(lcm,a[j])*a[j];
                if(lcm>n) break;
            }
        }
        if(num%2==0) res-=(n/lcm);
        else res+=(n/lcm);
    }
    printf("%d\n",res);
}

int main()
{

    while(~scanf("%d%d",&n,&m))
    {
        n--;
        int flag=1;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]==0)
            {
                i--;m--;
            }
        }
        solve();
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值